Bug 466170 - xml-rpc call packages.listChannelSourceBySession doesn't parse nvr correctly
xml-rpc call packages.listChannelSourceBySession doesn't parse nvr correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn507
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Stephen Herr
Red Hat Network Quality Assurance
us =1399
:
Depends On:
Blocks: 428922 rhn-sprint46
  Show dependency treegraph
 
Reported: 2008-10-08 16:23 EDT by Brandon Perkins
Modified: 2013-01-10 05:27 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 16:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brandon Perkins 2008-10-08 16:23:57 EDT
+++ This bug was initially created as a clone of Bug #460464 +++

Created an attachment (id=315196)
nvr split using RE

Description of problem:
when listing a channel srpms, I get:
['net', 'snmp', '5.1.2', '', 'rhel-i386-as-4']
instead of
['net-snmp', '5.1.2', '12.el4', '', 'rhel-i386-as-4']


Steps to Reproduce:
1. push a srpm with many dashes in it's name to a satellite
2. list sprms via packages.listChannelSourceBySession()


I made two patches doing the same thing:
 - first one uses RE to get n-v-r parts
 - the second one uses rsplit to get n-v-r

Patches were tested on RHEL-5/Python2.4.
Just choose the one which would work on all supported satellite versions...

--- Additional comment from dmach@redhat.com on 2008-08-28 07:06:25 EDT ---

Created an attachment (id=315197)
nvr split using rsplit

--- Additional comment from bperkins@redhat.com on 2008-10-08 12:30:20 EDT ---

While this may be a valid bug in Satellite for us to fix, it seems like you need this fixed in RHN Hosted.  Can you please confirm one of:

1) You want this fixed in RHN Hosted
2) You want this fixed in Satellite
3) You want this fixed in both RHN Hosted and Satellite

If 1, we'll be happy to realign it to them.  If 2, we'll triage it and see if we can get it into 530.  If 3, we'll clone the bug to Hosted so they can look at it while we look at it and maybe we can fix it in both.

--- Additional comment from dmach@redhat.com on 2008-10-08 14:03:43 EDT ---

Originally, I found this bug on Satellite.
Now I tried to reproduce it on Hosted (webqa) and I also got invalid results:
['system', 'config', 'network', '', 'rhel-i386-as-4']
['net', 'snmp', '5.1.2', '', 'rhel-i386-as-4']

I think that we want 3).

--- Additional comment from dmach@redhat.com on 2008-10-08 14:10:41 EDT ---

Created an attachment (id=319775)
reproducer

Push net-snmp or system-config-* rpm + srpm to the rhel-i386-as-4 channel.
Then setup and run this script.
Result should be lines with [name, version, release, epoch, channel] lists.

--- Additional comment from bperkins@redhat.com on 2008-10-08 16:22:20 EDT ---

Accepting this bug for Satellite 530 and will now clone for RHN Hosted.  Ideally once we have the fix, Hosted can just *borrow* it from us.
Comment 1 Amy Owens 2008-10-09 11:11:23 EDT
added user story: http://wwwapps.rdu.redhat.com:8080/xplanner/do/view/userstory?oid=53450
Comment 2 Daniel Mach 2009-01-19 13:00:39 EST
Hello, any progress?
I can't get srpm list and delete them from RHN,
because I get fancy NVREs such as ['yum', 'rhn', 'plugin', ''].

It's already fixed in the latest satellite using the rsplit approach:
https://bugzilla.redhat.com/show_bug.cgi?id=460464#c7

Note You need to log in before you can comment on or make changes to this bug.