Bug 466178 - Unknown device: "epswrite" converting to eps files.
Unknown device: "epswrite" converting to eps files.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Norm Murray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 17:39 EDT by Orion Poplawski
Modified: 2008-11-06 21:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 21:54:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Upgrade to 6.3.5.10 (2.16 KB, patch)
2008-10-13 12:24 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2008-10-08 17:39:55 EDT
Description of problem:

I'm getting:

convert dens.ps figs/spec1_U200_west_Prp7.eps
Unknown device: "epswrite"
Unrecoverable error: undefined in .uninstallpagedevice
Operand stack:
    defaultdevice
convert: Delegate failed `"gs" -q -dQUIET -dSAFER -dPARANOIDSAFE -dBATCH -dNOPAUSE -dNOPROMPT -dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=0 -sDEVICE="epswrite" -sOutputFile="%o" -f"%i"'. 

Apparently the same as:

http://www.mail-archive.com/magick-bugs@imagemagick.org/msg00450.html

the response to which indicates that this is fixed in 6.3.5-10.

So, I'd like to see an updated ImageMagick in F-8.  Whether this should be 6.3.5.10 or 6.3.8.1 from F-9 or something else (6.3.9-10?), I'm not sure.  I'm happy to push through the build once a decision on what version to use has been made.

Version-Release number of selected component (if applicable):
ImageMagick-6.3.5.9-1.fc8
Comment 1 Hans de Goede 2008-10-12 04:44:14 EDT
Hmm,

Given that F-8 is heading towards EOL soon, I'm tending towards closing this WONTFIX. People who are still with F-8 clearly like some sort of stability, so rebasing to a new upstream version this late in the cycle seems like a bad idea.
Comment 2 Orion Poplawski 2008-10-12 09:37:35 EDT
It seems a bump from 6.3.5.9 to 6.3.5.10 would be pretty minor.

At my location, we're stuck on F-8 because KDE 4 in F-9 was/is just not ready for prime time.  An extra two months on F-8 (with a working IM) with the hope of jumping to F-10 would be very helpful for us.

I'm happy to push the build through myself, if time/effort on your part is a concern.
Comment 3 Hans de Goede 2008-10-12 09:55:11 EDT
(In reply to comment #2)
> It seems a bump from 6.3.5.9 to 6.3.5.10 would be pretty minor.
> 
> At my location, we're stuck on F-8 because KDE 4 in F-9 was/is just not ready
> for prime time.  An extra two months on F-8 (with a working IM) with the hope
> of jumping to F-10 would be very helpful for us.
> 
> I'm happy to push the build through myself, if time/effort on your part is a
> concern.

Ok, go ahead, please put this through updates-testing. I'm not sure if the package is open for cvsextras in pkgdb (its a former core package), nor am I sure if I have the rights to open it (I'm a co-maintainer) so if necessary send the changes to me as patches and I'll do the commit and build for you.
Comment 4 Orion Poplawski 2008-10-13 12:24:24 EDT
Created attachment 320198 [details]
Upgrade to  6.3.5.10

Don't have commit rights.  Here's a patch.
Comment 5 Hans de Goede 2008-10-13 16:53:36 EDT
(In reply to comment #4)
> Created an attachment (id=320198) [details]
> Upgrade to  6.3.5.10
> 
> Don't have commit rights.  Here's a patch.

Ok, its building now:
http://koji.fedoraproject.org/koji/taskinfo?taskID=878362

I'm going to bed now I'll submit an update to updates-testing tomorrow, feel free to beat me to it, although I'm not sure if bodhi will allow you to create an update when you don't have CVS rights for a package.
Comment 6 Orion Poplawski 2008-10-13 17:46:06 EDT
Thanks.  Bodhi gives a 500 internal error when I try to save - and then I get that I don't have commit access.
Comment 7 Fedora Update System 2008-10-14 03:51:18 EDT
ImageMagick-6.3.5.10-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/ImageMagick-6.3.5.10-1.fc8
Comment 8 Fedora Update System 2008-10-20 16:27:26 EDT
ImageMagick-6.3.5.10-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ImageMagick'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-8917
Comment 9 Fedora Update System 2008-11-06 21:54:42 EST
ImageMagick-6.3.5.10-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.