Bug 466204 - tcsh parsing of /etc/sysconfig/lang.csh generates incorrect lstat calls
tcsh parsing of /etc/sysconfig/lang.csh generates incorrect lstat calls
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcsh (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Vojtech Vitek
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 02:26 EDT by Norm Murray
Modified: 2015-03-04 18:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:29:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed tcsh (863.20 KB, application/x-rpm)
2009-07-27 18:15 EDT, Charlie Wyse
no flags Details

  None (edit)
Description Norm Murray 2008-10-09 02:26:13 EDT
Description of problem:
When starting a tcsh it parses /etc/sysconfig/lang.csh and when executing this line: 
eval `grep -v '^[:blank:]*#' $file | sed 's|\([^=]*\)=\([^=]*\)|setenv \1 \2|g' | sed 's|$|;|'`

tcsh is calling lstat on:
lstat on setenv
lstat on LANG
lstat on "en_US.UTF-8";
lstat on setenv
lstat on SUPPORTED
lstat on "en_US.UTF-8:en_US:en";
lstat on setenv
lstat on SYSFONT
lstat on "latarcyrheb-sun16";
(generated from a printf before the lstat call in glob.c)

Obviously this is incorrect and is not normally a problem, but when a new shell is invoked while cwd is in an automount directory this generates automount attempts which can spam the logs. 

tcsh 6.15 still shows a problem parsing this in context, though the /etc/sysconfig/lang.csh in more recent initscripts has changed so if LANG is already set this line of code is not executed.
Comment 1 Issue Tracker 2009-04-29 15:23:13 EDT
nmurray,
  Any word on a fix for this?  Just opened a ticket for RHEL5 and wanted
to check in on status since it will effect both.


This event sent from IssueTracker by cwyse 
 issue 208860
Comment 2 Charlie Wyse 2009-07-27 18:15:01 EDT
Created attachment 355324 [details]
fixed tcsh

Here is the SRPM for tcsh with the patch from BZ498625 .
Comment 3 RHEL Product and Program Management 2010-10-22 14:50:19 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.