This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 466220 - The node4.priv.ovirt.org doesn't display in Add Host dialogue
The node4.priv.ovirt.org doesn't display in Add Host dialogue
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Perry Myers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 05:01 EDT by koka xiong
Modified: 2016-04-26 21:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 16:04:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description koka xiong 2008-10-09 05:01:23 EDT
Description of problem:
After run "virsh start node4" to start virtual machine,the node4.priv.ovirt.org host doesn't display in Add Host dialogue.

Version-Release number of selected component (if applicable):
0.93

How reproducible:


Steps to Reproduce:
1.* Start the virtual machine in the host
# virsh start node3
# virsh start node4
# virsh start node5
2.Open the oVirt Administration User Interface
3.From the Hosts toolbar,click Add Host (or click "Add first host to this hardware pool" if no hosts found in this pool.)


Actual results:
The Add Host dialog box displays which displays the availability and usage statistics of the available hosts, these include:

node3.priv.ovirt.org
node5.priv.ovirt.org

Expected results:
The Add Host dialog box should include the following ones:
node3.priv.ovirt.org
node4.priv.ovirt.org
node5.priv.ovirt.org

Additional info:
Comment 1 Perry Myers 2008-10-09 16:04:40 EDT
node3-5 are used only for development and testing of the Node installation and persistence model by developers.  We will not be supporting the 'fake Nodes' in the Product.  All QE testing should be done using either real Nodes (oVirt Node running on physical hardware) or VMs running directly on the Appliance Host (physical.priv.ovirt.org)

For reference, the reason why Node 4 does not show up is because by default node4 is configured to install itself to the virtual disk located at /var/lib/libvirt/images/node4.img.  The Node boots, installs itself and then halts.  After node4 is shutdown, you should run the ovirt-fake-node-boot script located in the ovirt-release repository in the misc-scripts directory.

./ovirt-fake-node-boot node4 hd

This will toggle node4 to boot to the node image that was installed onto the virtual hard disk.

But again, the above procedures are really only meant for developers, so you should not need to test this.

Note You need to log in before you can comment on or make changes to this bug.