Bug 466229 - SELinux is preventing the npviewer.bin from using potentially mislabeled files
SELinux is preventing the npviewer.bin from using potentially mislabeled files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 05:40 EDT by Gianluca Varisco
Modified: 2015-10-25 21:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 07:02:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Varisco 2008-10-09 05:40:49 EDT
Description of problem:

SELinux has denied npviewer.bin access to potentially mislabeled file(s) (./s.ytimg.com). This means that SELinux will not allow npviewer.bin to use these files. It is common for users to edit files in their home directory or tmp directories and then move (mv) them to system directories. The problem is that the files end up with the wrong file context which confined applications are not allowed to access. 


Version-Release number of selected component (if applicable):

nspluginwrapper-1.1.0-11.fc10.x86_64
selinux-policy-3.5.10-3.fc10.noarch

How reproducible:

- Open any youtube video, such as http://it.youtube.com/watch?v=dvgZkm1xWPE
- an AVC denial appears.
  
Actual results:

SELinux is preventing the npviewer.bin from using potentially mislabeled files
(./s.ytimg.com).

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                ./s.ytimg.com [ dir ]
Source                        npviewer.bin
Source Path                   /usr/lib/nspluginwrapper/npviewer.bin
Port                          <Unknown>
Host                          gvarisco.milan.redhat.com
Source RPM Packages           nspluginwrapper-1.1.0-11.fc10
Target RPM Packages           
Policy RPM                    selinux-policy-3.5.10-3.fc10
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   home_tmp_bad_labels
Host Name                     gvarisco.milan.redhat.com
Platform                      Linux gvarisco.milan.redhat.com
                              2.6.27-0.398.rc9.fc10.x86_64 #1 SMP Mon Oct 6
                              21:52:11 EDT 2008 x86_64 x86_64
Alert Count                   326
First Seen                    Thu 09 Oct 2008 08:57:02 AM CEST
Last Seen                     Thu 09 Oct 2008 11:37:42 AM CEST
Local ID                      0f0be52e-c384-47f8-8a4c-7166c813de3d
Line Numbers                  

Raw Audit Messages            

node=gvarisco.milan.redhat.com type=AVC msg=audit(1223545062.959:404): avc:  denied  { write } for  pid=13916 comm="npviewer.bin" name="s.ytimg.com" dev=dm-1 ino=2761377 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=gvarisco.milan.redhat.com type=SYSCALL msg=audit(1223545062.959:404): arch=40000003 syscall=5 per=8 success=no exit=-13 a0=f6f1a860 a1=442 a2=1b6 a3=ede00c10 items=0 ppid=3450 pid=13916 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="npviewer.bin" exe="/usr/lib/nspluginwrapper/npviewer.bin" subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)

Anyway, I'm able to see the video and hear the audio, it just displays this denial that you may fix ;-)

Many thanks, as always!
Comment 1 Gianluca Varisco 2008-10-09 05:44:13 EDT
See also http://www.siteadvisor.fr/sites/ytimg.com/ ,  seems to be an external domain used by Google/Youtube for contents.
Comment 2 Daniel Walsh 2008-10-09 07:02:11 EDT
Labeling problem

restorecon -R -v ~

In order to use nsplugin your home directory needs to be labeled correctly.

I think your ~/.macromedia directory has the wrong labels.

You can use the service restorecond to make sure your homedir is labeled correctly after the restorecon.

Note You need to log in before you can comment on or make changes to this bug.