Bug 466290 - Add/Remove Software fails on it's first action
Add/Remove Software fails on it's first action
Status: CLOSED DUPLICATE of bug 469950
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 11:37 EDT by Joshua Coombs
Modified: 2008-11-06 05:58 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 05:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Coombs 2008-10-09 11:37:58 EDT
Description of problem:

The first time you hit apply after marking or unmarking packages for instalation or removal in 'Add/Remove Programs' the action fails out with an 'unknown error'.  The details are:
Method "InstallPackages" with signature "as" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist


Version-Release number of selected component (if applicable):
PackageKit-0.3.6-2.fc10.i386


How reproducible:


Steps to Reproduce:
1. Clean install of FC10 beta, gnome desktop, apply all updates as of 11:32am EST 10/9/08
2. Open Add/Remove Software
3. In the 'Games' category, select 'apricots'
4. Click 'Apply'
5. A new dialog box will pop up, showing progress...
6. Authenticate when asked
7. A new dialog box will pop up with the error message, close it and the prior progress dialog box.
8. Click 'Apply' again, the progress dialog box will appear, the install will go through cleanly, and you'll be asked if you want to run your new app.  Any further install/uninstall actions will proceed normally as long as you don't restart Add/Remove Software.

Actual results:
First install/uninstall fails, all after proceed normally

Expected results:
First install/uninstall should work without error

Additional info:
Doesn't seem to matter if the first install/uninstall pulls in additional packages for changes, or if you select multiple for the first action.
Comment 1 Richard Hughes 2008-10-09 11:58:36 EDT
I think I've found the bug in PkControl, I'll commit this upstream, then roll a package.
Comment 2 Richard Hughes 2008-10-09 12:02:23 EDT
When the new packages have built in http://koji.fedoraproject.org/koji/taskinfo?taskID=871330 -- can you try those please. Thanks.
Comment 3 Joshua Coombs 2008-10-09 13:09:47 EDT
I upgraded to PackageKit-0.3.6-3.fc10.i386 using the rpm's you linked to, still getting the same behavior and error.
Comment 4 Joshua Coombs 2008-10-14 13:27:58 EDT
I can not reproduce the error after updating this afternoon.  I see I'm now running PackageKit-0.3.7-1.fc10.i386
Comment 5 Joshua Coombs 2008-10-22 14:20:24 EDT
Gah, I marked this bug as closed too quickly, just ran into it again trying to install Audacious.

PackageKit-0.3.7-1.fc10.i386
Comment 6 Kåre Løvgren 2008-10-24 11:45:44 EDT
I get the same error using PackageKit-0.3.8-2.fc10.i386 on Fedora 10 beta (2.6.27.3-34.rc1.fc10.i686, all updates applied).
Comment 7 Richard Hughes 2008-11-06 05:58:53 EST

*** This bug has been marked as a duplicate of bug 469950 ***

Note You need to log in before you can comment on or make changes to this bug.