Bug 466338 - I: memblock.c: Pool full
I: memblock.c: Pool full
Status: CLOSED DUPLICATE of bug 462200
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-09 15:33 EDT by James Laska
Modified: 2013-09-02 02:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 17:16:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pulseaudio -vvvv output (97.26 KB, text/plain)
2008-10-09 15:33 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2008-10-09 15:33:28 EDT
Created attachment 319917 [details]
pulseaudio -vvvv  output

Description of problem:

Clicking "Sound Capture->Test" in gnome-sound-properties with ALSA selected results in:

I: memblock.c: Pool full
I: memblock.c: Pool full
I: memblock.c: Pool full
I: memblock.c: Pool full
I: memblock.c: Pool full

Version-Release number of selected component (if applicable):

alsa-lib-1.0.18-6.rc3.fc10.x86_64
alsa-plugins-pulseaudio-1.0.18-1.rc3.fc10.x86_64
alsa-utils-1.0.18-3.rc3.fc10.x86_64
kernel-2.6.27-0.391.rc8.git7.fc10.x86_64
kernel-2.6.27-0.392.rc8.git7.fc10.x86_64
kernel-2.6.27-0.398.rc9.fc10.x86_64
pulseaudio-0.9.13-1.fc10.x86_64
pulseaudio-core-libs-0.9.13-1.fc10.x86_64
pulseaudio-esound-compat-0.9.13-1.fc10.x86_64
pulseaudio-libs-0.9.13-1.fc10.x86_64
pulseaudio-libs-glib2-0.9.13-1.fc10.x86_64
pulseaudio-module-gconf-0.9.13-1.fc10.x86_64
pulseaudio-module-x11-0.9.13-1.fc10.x86_64
pulseaudio-utils-0.9.13-1.fc10.x86_64

How reproducible:


Steps to Reproduce:
1. Start gnome-sound-properties
2. Select "Devices" tab
3. Under "Sound Capture", select "ALSA"
4. Click "Test"
  
Actual results:
 * pulseaudio -vvvv shows emits the following message a lot 

I: memblock.c: Pool full

Expected results:
 * pulseaudio should not die

Additional info:

 * System/Sound card information available at http://www.alsa-project.org/db/?f=0bba90565883dc921f97eeb910e9bc30076b30cd

 * If I click OK in the testing dialog ... the UI freezes.
Comment 1 John Poelstra 2008-10-09 15:37:57 EDT
seeing the same thing with 13.2 packages on i386f
Comment 2 Hans Ulrich Niedermann 2008-10-09 16:08:06 EDT
Seeing the same thing here, although I do see some

I: module-alsa-source.c: Overrun!

as well, every 8 to 20 lines of

I: memblock.c: Pool full
Comment 3 Matthias Clasen 2008-10-17 10:37:40 EDT
I: memblock.c: Pool full

Is this informational message actually a problem ?
Is this a blocker ?
Comment 4 James Laska 2008-10-17 10:44:38 EDT
THe end result is that pulseaudio exits.  I believe that isn't the expected result.  I'm not sure if the "memblock.c: Pool full" contributes to the failure, or if it's informational.
Comment 5 Hans Ulrich Niedermann 2008-10-17 15:52:40 EDT
Having the "pool full" message appear 10 times a second, and "Overrun" messages in between, and then having pulseaudio exit... I'd think the messages themselves are not a problem, but something within pulseaudio is going wrong and the messages are indicating what that might be.
Comment 6 Lennart Poettering 2008-10-22 22:31:36 EDT
The pool full message is usually a sign that some client doesn't unref the data blocks it read from PA quickly enough.
Comment 7 Lennart Poettering 2008-10-24 17:16:00 EDT
I think this is simply another duplicate of 462200. At least I assume that "pulseaudio exits" refers to the CPU load limiter.

*** This bug has been marked as a duplicate of bug 462200 ***

Note You need to log in before you can comment on or make changes to this bug.