This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 466343 - Provide ipmievd init script, update ipmitool to 1.8.10
Provide ipmievd init script, update ipmitool to 1.8.10
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: OpenIPMI (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 15:57 EDT by Ville Skyttä
Modified: 2008-10-23 03:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipmitool-1.8.10
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 03:34:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update ipmitool, install ipmievd init script, other minor changes (12.16 KB, patch)
2008-10-09 15:57 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2008-10-09 15:57:10 EDT
Created attachment 319921 [details]
Update ipmitool, install ipmievd init script, other minor changes

Attached is a patch that updates ipmitool to 1.8.10, installs an init script for ipmievd, and configures with dependency tracking disabled and uses parallel make for possible slight build speedup.


Other issues not addressed in this patch I noticed when looking into the package:

1) BuildRequires: tcl-devel would result in some TCL support built in.  Not sure if it's desirable though, but would be good to explicitly enable/disable it for reproducible builds.

2) A private copy of libedit is used; would be good to make use of the separately packaged system libedit.

3) A GUI is included in the sources, but not installed.  Is this on purpose?

4) ipmitool seems to be capable of using freeipmi as well.  I haven't tried it but I suppose "BuildRequires: freeipmi-devel" would build it in.  Same thing as comment 1) about reproducible builds applies, but wouldn't it make sense to split ipmitool into a completely separate package instead of bundling it in here?

The Mandriva openipmi package seems to have a bunch of improvements over the Fedora/EL one, such as TCL support, UI (whose separation allows fewer dependencies in the main package, e.g. TCL) and GUI subpackages.
Comment 1 John Poelstra 2008-10-09 18:04:09 EDT
This bug has been triaged
Comment 2 Ville Skyttä 2008-10-12 15:49:57 EDT
"Other issues" moved to merge review bug 226212, please follow up on them there.
Comment 3 Jan Safranek 2008-10-23 03:34:11 EDT
ipmitool-1.8.10 is now packaged separately in rawhide and it provides ipmievd init script. See the review for the rest of reported issues.

Note You need to log in before you can comment on or make changes to this bug.