Bug 466345 - Kernel panic on shutdown
Kernel panic on shutdown
Status: CLOSED DUPLICATE of bug 456664
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Ivan Vecera
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 16:05 EDT by Marcus Alves Grando
Modified: 2008-10-10 10:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 10:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Alves Grando 2008-10-09 16:05:01 EDT
I received kernel panic in one server when I tried shutdown.

Crash info:

      KERNEL: /usr/lib/debug/lib/modules/2.6.9-78.0.1.ELsmp/vmlinux
    DUMPFILE: /var/crash/127.0.0.1-2008-10-09-18:58/vmcore  [PARTIAL DUMP]
        CPUS: 4
        DATE: Thu Oct  9 18:58:31 2008
      UPTIME: 5 days, 23:59:35
LOAD AVERAGE: 0.08, 0.02, 0.01
       TASKS: 95
    NODENAME: urana
     RELEASE: 2.6.9-78.0.1.ELsmp
     VERSION: #1 SMP Tue Aug 5 11:02:47 EDT 2008
     MACHINE: i686  (2992 Mhz)
      MEMORY: 1 GB
       PANIC: "Oops: 0000 [#1]" (check log for details)
         PID: 28851
     COMMAND: "modprobe"
        TASK: f6de8830  [THREAD_INFO: f6c91000]
         CPU: 0
       STATE: TASK_RUNNING (PANIC)

crash> bt
PID: 28851  TASK: f6de8830  CPU: 0   COMMAND: "modprobe"
 #0 [f6c91dd0] disk_dump at f8b151b2
 #1 [f6c91dd4] printk at c0122b4b
 #2 [f6c91de0] freeze_other_cpus at f8b14ef5
 #3 [f6c91df0] start_disk_dump at f8b14faa
 #4 [f6c91e00] try_crashdump at c0134fda
 #5 [f6c91e08] die at c0106049
 #6 [f6c91e3c] do_page_fault at c011b27c
 #7 [f6c91f1c] error_code (via page_fault) at c02e14cd
    EAX: 00000002  EBX: c035e784  ECX: f726b6c0  EDX: f89725e0  EBP: f6c91000 
    DS:  007b      ESI: f8aa87e0  ES:  007b      EDI: 00000000
    CS:  0060      EIP: c0294b1a  ERR: ffffffff  EFLAGS: 00010216 
 #8 [f6c91f58] nf_unregister_sockopt at c0294b1a
 #9 [f6c91f6c] sys_delete_module at c01373c8
#10 [f6c91fc0] system_call at c02e09d0
    EAX: 00000081  EBX: 095d7be8  ECX: 00000080  EDX: 095d7b94 
    DS:  007b      ESI: 00000000  ES:  007b      EDI: 095d7be8
    SS:  007b      ESP: bfe45574  EBP: bfe455b8
    CS:  0073      EIP: 007707a2  ERR: 00000081  EFLAGS: 00000246 

I have vmcore if need.

Regards
Comment 1 Ivan Vecera 2008-10-10 08:23:03 EDT
What about reproducibility? Is this issue reproducible?
Comment 2 Ivan Vecera 2008-10-10 08:41:44 EDT
I found similar issue #456664. I could be the same problem.
1) Please try to run "/etc/init.d/iptables stop" on this system. Any oops?
2) Try updated RHEL4 kernel available at http://people.redhat.com/vgoyal/rhel4. It should solve this problem.
Comment 3 Marcus Alves Grando 2008-10-10 09:03:31 EDT
(In reply to comment #2)
> I found similar issue #456664. I could be the same problem.
> 1) Please try to run "/etc/init.d/iptables stop" on this system. Any oops?

Yes. Same thing.

> 2) Try updated RHEL4 kernel available at http://people.redhat.com/vgoyal/rhel4.
> It should solve this problem.

Ok. I saw in changelog.

It's possible release one errata for this?
Comment 4 Ivan Vecera 2008-10-10 10:08:03 EDT

*** This bug has been marked as a duplicate of bug 456664 ***

Note You need to log in before you can comment on or make changes to this bug.