Bug 466358 - Kernel panics with Qlogic QLA2342 on IA32 platforms
Kernel panics with Qlogic QLA2342 on IA32 platforms
Status: CLOSED DUPLICATE of bug 465945
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
high Severity high
: beta
: ---
Assigned To: Marcus Barrow
Martin Jenner
: Regression
Depends On:
  Show dependency treegraph
Reported: 2008-10-09 17:03 EDT by Tom Tracy
Modified: 2008-10-15 18:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-10-15 18:26:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom Tracy 2008-10-09 17:03:41 EDT
Description of problem:

systems Crash when plugging Qlogic QLA2342 - 133MHz PCI-X to 2Gb FC, Dual Channel  
Card into Qlogic 5500 Fiber Switch

Version-Release number of selected component (if applicable):

How reproducible:

Happens on all four nodes to the cluster. When unplugged from Fiber switch, systems do not crash. 

Steps to Reproduce:
1. Plug wire from Qlogic Card to Qlogic Fiber switch
2. Power on Machine and boots starts
3. Kernel panics (only have partial since there is no buffer to ilo)
Actual results:

Kernel Panics: This is what I have captured
ss fc_wq_1 (pid: 767, ti=df91f000 task=dfb84000 task.ti=df91f000)          
Stack: 00000000 dfb7cd40 c3210360 dfcbd448 dfcbd400 dfc30400 dfcbd448 f8bb3bf1  
       c32100ec f8925156 c3210000 dfcbd400 f89268d1 dfcbd65c dfcbd660 df98d8c0  
       00000286 c04328da f892686d dfcbd400 df98d8d4 df98d8c0 df98d8cc 00000000  
Call Trace:                                                                     
 [<f8bb3bf1>] qla2x00_terminate_rport_io+0x10/0x18 [qla2xxx]                    
 [<f8925156>] fc_terminate_rport_io+0x38/0x46 [scsi_transport_fc]               
 [<f89268d1>] fc_rport_final_delete+0x64/0x8f [scsi_transport_fc]               
 [<c04328da>] run_workqueue+0x78/0xb5                                           
 [<f892686d>] fc_rport_final_delete+0x0/0x8f [scsi_transport_fc]                
 [<c043318e>] worker_thread+0xd9/0x10b                                          
 [<c041f457>] default_wake_function+0x0/0xc                                     
 [<c04330b5>] worker_thread+0x0/0x10b                                           
 [<c043559d>] kthread+0xc0/0xeb                                                 
 [<c04354dd>] kthread+0x0/0xeb                                                  
 [<c0405c53>] kernel_thread_helper+0x7/0x10                                     
Code: c5 fd ff ff 85 c0 c7 44 24 04 02 20 00 00 74 84 e9 3a ff ff ff 8b 44 24 04
 83 c4 18 5b 5e 5f 5d c3 55 57 56 53 83 ec 0c 89 04 24 <8b> 78 08 8b af f4 14 00
 00 85 ed 0f 44 ef 8d 85 80 00 00 00 89                                         
EIP: [<f8b9d482>] qla2x00_abort_fcport_cmds+0xa/0xff [qla2xxx] SS:ESP 0068:df91f
 <0>Kernel panic - not syncing: Fatal exception                                 
-virt11, ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEAorOlX05F1vl84Nleixi6i7eEIIm9unYSxkltNFanMRtkTV9eq0pa5L4/4/j0j5ayL2bdHAUqUstiHni4CVZsH64uU0mSVqJWDY01MIsRihwVF48OpPTiW3GRqX7MIcVrsMiJUu89GGNM3i8oU9

Expected results:

Systems should boot normally and see created storage presented to nodes. Also unplugged storage and still machine crashes

Additional info:

When installing RHEL53 from PXE, saw same behavior. Unplugged cables and OS installed fine. Then tried installing RHEL52 with fiber cables plugged in and no  
problems was observed.
Comment 2 RHEL Product and Program Management 2008-10-14 00:30:13 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 3 RHEL Product and Program Management 2008-10-14 17:38:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 5 Tom Coughlan 2008-10-15 18:26:48 EDT

*** This bug has been marked as a duplicate of bug 465945 ***

Note You need to log in before you can comment on or make changes to this bug.