Bug 466364 - gcstar crashes when fetching movie information
gcstar crashes when fetching movie information
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gcstar (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Christian Jodar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 17:10 EDT by Steven Bakker
Modified: 2008-11-05 23:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 23:09:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Bakker 2008-10-09 17:10:18 EDT
Description of problem:

When attempting to add a movie in gcstar and using the "Fetch Information" function, the pop-up window stating "Search in progress..." freezes after a few seconds. In the terminal session from where I started gcstar it says:

Can't store CODE items at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/_store_fd.al) line 304, at /usr/bin/../lib/gcstar/GCPlugins.pm line 146

Version-Release number of selected component (if applicable):

1.4.1-1.fc9.noarch

How reproducible:

Always

Steps to Reproduce:
1. Start up gcstar from the command line.
2. Click on "Add" in the toolbar.
3. Enter the name of a movie (any name will do).
4. Click "Fetch Information".
5. Select a data source in the dialog window that comes up and click "Fetch Information"

Actual results:

A pop-up window comes up, saying "Search in progress..." with an animated progress bar. After a few seconds, the bar stops moving and the command line shows:

Can't store CODE items at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/_store_fd.al) line 304, at /usr/bin/../lib/gcstar/GCPlugins.pm line 146

The application hangs at this point. Killing it by clicking the close button on the frame and having gnome force-quit the application produces an additional message:

Magic number checking on storable file failed at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/fd_retrieve.al) line 398, <RCOMMAND> line 1, at /usr/bin/../lib/gcstar/GCPlugins.pm line 96

Expected results:

The search completes and gives a list of possible matches.

Additional info:

I'm not sure whether this is due to some file corruption on my local data (I cannot find where gcstar stores my movie information), or because of recent updates.
Comment 1 Fedora Update System 2008-10-12 05:04:17 EDT
gcstar-1.4.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/gcstar-1.4.3-1.fc9
Comment 2 Fedora Update System 2008-10-15 22:09:43 EDT
gcstar-1.4.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gcstar'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8855
Comment 3 Steven Bakker 2008-11-01 17:00:27 EDT
Hi, sorry for taking so long to respond.

I tested the update (from updates-testing-newkey, rather than updates-testing), and the program no longer crashes. It still produces warnings though:

Can't store item CODE(0xa5ff964) at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/_store_fd.al) line 304.

However, gcstar seems to work fine and no longer crashes.
Comment 4 Christian Jodar 2008-11-03 00:56:58 EST
Hi,

Thank you for your feedback. I didn't manage to remove this warning. But it's harmless as you noticed.

This version as been submitted to stable updates. There should be a notification here when it will be available.
Comment 5 Fedora Update System 2008-11-05 23:08:58 EST
gcstar-1.4.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.