Bug 466368 - SIGSEGV at luksOpen of not existent device
SIGSEGV at luksOpen of not existent device
Status: CLOSED DUPLICATE of bug 438978
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks (Show other bugs)
8
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 17:22 EDT by Mike
Modified: 2008-10-09 17:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-09 17:28:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2008-10-09 17:22:30 EDT
[root@localhost ~]# rpm -q cryptsetup-luks-debuginfo
cryptsetup-luks-debuginfo-1.0.5-7.fc8

[root@localhost ~]# gdb cryptsetup
GNU gdb Red Hat Linux (6.6-45.fc8rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) run luksOpen /dev/sdwxws asd123

Starting program: /sbin/cryptsetup luksOpen /dev/sdwxws asd123

Program received signal SIGSEGV, Segmentation fault.
LUKS_dealloc_masterkey (mk=0xc) at /usr/include/bits/string3.h:136
warning: Source file is more recent than executable.
136           && (!__builtin_constant_p (__n) || __n <= __bos (__dest)))
(gdb) bt
#0  LUKS_dealloc_masterkey (mk=0xc) at /usr/include/bits/string3.h:136
#1  0x00610b37 in __crypt_luks_open (arg=0, backend=0x61a958, options=0xbfc6d380) at setup.c:678
#2  0x0060f835 in crypt_job (job=0x6108b0 <__crypt_luks_open>, arg=0, options=0xbfc6d380)
    at setup.c:795
#3  0x0804954f in action_luksOpen (arg=0) at cryptsetup.c:251
#4  0x08049c1b in main (argc=Cannot access memory at address 0x0
) at cryptsetup.c:474
#5  0x004c8390 in __libc_start_main (main=0x8049970 <main>, argc=4, ubp_av=0xbfc6d554,
    init=0x804a080 <__libc_csu_init>, fini=0x804a070 <__libc_csu_fini>,
    rtld_fini=0x4a1940 <_dl_fini>, stack_end=0xbfc6d54c) at libc-start.c:220
#6  0x08048f11 in _start ()
Comment 1 Mike 2008-10-09 17:28:21 EDT

*** This bug has been marked as a duplicate of bug 438978 ***

Note You need to log in before you can comment on or make changes to this bug.