Bug 466370 - blank graphical welcome screen for DVD install
blank graphical welcome screen for DVD install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-09 17:38 EDT by John Reiser
Modified: 2013-01-09 23:50 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 19:18:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/X.log (71.24 KB, text/plain)
2008-10-09 17:38 EDT, John Reiser
no flags Details
anaconda.log (1.91 KB, text/plain)
2008-10-09 17:39 EDT, John Reiser
no flags Details
lspci; lspci -n; lspci -v (12.05 KB, text/plain)
2008-10-09 17:40 EDT, John Reiser
no flags Details
/var/log/Xorg.0.log from working Fedora 9 (56.76 KB, text/plain)
2008-10-10 16:12 EDT, John Reiser
no flags Details
/tmp/syslog when installer's graphical welcome screen is blank (39.22 KB, text/plain)
2008-10-27 16:29 EDT, John Reiser
no flags Details
/tmp/X.log when installer's graphical welcome screen is blank (67.88 KB, text/plain)
2008-10-27 16:30 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2008-10-09 17:38:23 EDT
Created attachment 319946 [details]
/tmp/X.log

Description of problem: The graphical welcome screen is blank except for a blinking text cursor in the upper left corder.  This is a graphical install using DVD composed by pungi from yesterday's rawhide (Wed.Oct. 9).  vty1 through vty5 have text, vty6 has no video signal, vty7 is blank except for blinking underline text cursor in upper left corner.


Version-Release number of selected component (if applicable):
anaconda-11.4.1.44
xorg-x11-server-common-1.5.1-10.fc10.i386.rpm
kernel-2.6.27-0.398.rc9.fc10.i686.rpm

How reproducible: always


Steps to Reproduce:
1. boot DVD, select Install or upgrade
2.
3.
  
Actual results: Graphical welcome screen is blank except for blinking underline text cursor in upper left.


Expected results: Graphical welcome screen.


Additional info: Text mode (add " text" to end of boot command) gets text welcome screen (and immediate exception after OK; will be BZ'ed.)
Comment 1 John Reiser 2008-10-09 17:39:38 EDT
Created attachment 319947 [details]
anaconda.log
Comment 2 John Reiser 2008-10-09 17:40:38 EDT
Created attachment 319950 [details]
lspci; lspci -n; lspci -v
Comment 3 John Reiser 2008-10-10 13:04:54 EDT
The problem persists with today's rawhide:
anaconda-11.4.1.47
kernel-2.6.27-1.fc10.i686.rpm
xorg-x11-server-common-1.5.1-10.fc10.i386.rpm
xorg-x11-server-Xvfb-1.5.1-10.fc10.i386.rpm
xorg-x11-drv-ati-6.9.0-25.fc10.i386.rpm
Comment 4 John Reiser 2008-10-10 16:12:53 EDT
Created attachment 320058 [details]
/var/log/Xorg.0.log from working Fedora 9

Same hardware runs Fedora 9 just fine; here is the Xorg.0.log.
Comment 5 John Reiser 2008-10-13 12:20:02 EDT
On different hardware, the R128 driver (ATI Rage 128 chipsets) works.  The PCI id is 1002:4c46 (rev 02), ATI Technologies Inc Rage Mobility M3 AGP 2x.

Still other hardware also works: NV: driver for NVIDIA chipsets, PCI 10de:0163 (rev a1) nVidia Corporation NV44 [GeForce 6200 LE].
Comment 6 John Reiser 2008-10-14 14:10:25 EDT
Today's rawhide (Tue.Oct.14) gets the same net results (Radeon bad; R128 and NV good) but there may be some improvement.  For about 1/4 of a second, I see a "graphical" screen, but scrunched into the top 1/5 of the display, and distorted as if being torn off from a pad of paper. [This is definitely not the "Starting anaconda 11.4.1.48 ..." screen which has mostly a solid blue background.  However, I cannot tell if this is the remnants of the GRUB boot splssh screen, or if it is the anaconda graphical welcome screen.] Then the screen goes black, but switching virtual consoles (away and back) brings up the blinking text underline cursor on vty7.

kernel-2.6.27-3.fc10.i686.rpm
xorg-x11-drv-ati-6.9.0-26.fc10.i386.rpm
xorg-x11-server-common-1.5.2-2.fc10.x86_64.rpm
xorg-x11-server-Xvfb-1.5.1-10.fc10.i386.rpm
Comment 7 Jesse Keating 2008-10-17 14:10:05 EDT
Hrm, I'm not sure this is a snapshot blocker.  Moving it over to F10 blocker.
Comment 8 John Reiser 2008-10-17 15:21:37 EDT
On today's rawhide, graphical install still gets the blank graphical welcome screen.  Text install works, and X11 works on the resulting system (after "user add <name>; password <name>; telinit 5").  Why does X11 work after being installed, but not during installation itself?

kernel-PAE-2.6.27.2-23.rc1.fc10.i686
xorg-x11-drv-ati-6.9.0-27.fc10.i386.rpm
xorg-x11-drv-fbdev-0.3.1-7.fc9.i386.rpm
xorg-x11-server-common-1.5.2-5.fc10.i386.rpm
Comment 9 John Reiser 2008-10-27 16:28:03 EDT
Today's rawhide still gets the blank graphical welcome screen on Radeon during early install, upon first switch to graphical mode.

Looking at /tmp/syslog (also on vt4; will be attached), I see
-----
<6>pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
<4>mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining
-----
where the 'mtrr: type mismatch" message does _not_ appear during regular booting (non-install) when the mode switch to graphical succeeds.

kernel-2.6.27.4-51.fc10.i586
xorg-x11-drv-ati-6.9.0-31.fc10.i386.rpm
xorg-x11-server-common-1.5.2-9.fc10.i386.rpm
xorg-x11-drv-fbdev-0.3.1-7.fc9.i386.rpm
Comment 10 John Reiser 2008-10-27 16:29:47 EDT
Created attachment 321655 [details]
/tmp/syslog when installer's graphical welcome screen is blank

note "mtrr: type mismatch" message at line 739.
Comment 11 John Reiser 2008-10-27 16:30:30 EDT
Created attachment 321656 [details]
/tmp/X.log when installer's graphical welcome screen is blank
Comment 12 John Reiser 2008-11-01 19:18:33 EDT
This now works for me using today's rawhide (Sat.Nov. 1; .rpms have been signed for a day or two.)  The installer's graphical welcome screen switches from text to graphics mode, and displays the correct graphical picture, and allows proceeding with the install.

kernel-2.6.27.4-68.fc10.i586
xorg-x11-drv-ati-6.9.0-38.fc10.i386

Note You need to log in before you can comment on or make changes to this bug.