Bug 466386 - PackageKit can't install (missing dbus interface?)
PackageKit can't install (missing dbus interface?)
Status: CLOSED DUPLICATE of bug 469950
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-09 20:05 EDT by James Antill
Modified: 2008-11-06 06:01 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-06 06:01:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Antill 2008-10-09 20:05:41 EDT
Description of problem:
 After asking PackageKit to install a bunch of things, packagekit brought up a box that said:

Method "InstallPackages" with signature "as" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist

Version-Release number of selected component (if applicable):

% yum list installed '*packagekit*'
Installed Packages
PackageKit.x86_64                    0.3.6-2.fc10               installed       
PackageKit-libs.x86_64               0.3.6-2.fc10               installed       
PackageKit-udev-helper.x86_64        0.3.6-2.fc10               installed       
PackageKit-yum.x86_64                0.3.6-2.fc10               installed       
PackageKit-yum-plugin.x86_64         0.3.6-2.fc10               installed       
gnome-packagekit.x86_64              0.3.6-2.fc10               installed
Comment 1 James Antill 2008-10-09 20:07:31 EDT
 The above probably requires a lot of s/packagekit/gnome-packagekit/ as it was from gpk-application ... but I assume the problem is not gnome-packagekit specific.
Comment 2 Richard Hughes 2008-10-10 13:38:52 EDT
EEek. That looks like the daemon crashed. Could you try reproducing with /usr/sbin/packagekitd under gdb please? Thanks.
Comment 3 Alex Lancaster 2008-10-13 22:13:16 EDT
I can duplicate the same problem when using the plugin installer helper.

1. use totem to try to play a file without a codec.
2. click "Search" to locate plugin
3. it finds gstreamer-plugins-bad
4. click to install
5. enter authorization details
6. comes up with "Installing Packages" progress bar
7. suddenly halts with a "Failed to install package" with the following in the details:

Method "InstallPackages" with signature "as" on interface "org.freedesktop.PackageKit.Transaction" doesn't exist

$ rpm -q PackageKit
Comment 4 Richard Hughes 2008-10-14 04:44:05 EDT
It works for me, but it's good it's reproducable as I can give you some more instructions :-)

Can you (as root) do:

killall packagekitd
/usr/sbin/packagekitd --verbose --disable-timer

and then try to reproduce the crash? You should have a metric ton of debugging output, please can you save it _all_ and attach it to this bug. Hopefully (?!) the daemon crashes, and we see what it was doing.

Comment 5 Alex Lancaster 2008-10-14 06:02:08 EDT
Next time I tried doing it (after a reboot) it worked as advertised.  Reproducing it could be a little tricky, but if it comes up again, I'll try the debugging steps.
Comment 6 Richard Hughes 2008-10-26 12:35:10 EDT
Okay, thanks.
Comment 7 Richard Hughes 2008-11-06 06:01:28 EST

*** This bug has been marked as a duplicate of bug 469950 ***

Note You need to log in before you can comment on or make changes to this bug.