Bug 466444 - gdm crashes from dbus_abort()
gdm crashes from dbus_abort()
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 06:01 EDT by Denis Leroy
Modified: 2015-01-14 18:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 09:45:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDM stack trace (7.59 KB, application/octet-stream)
2008-10-10 06:01 EDT, Denis Leroy
no flags Details
GDM trace (7.77 KB, application/octet-stream)
2008-10-10 07:57 EDT, Denis Leroy
no flags Details

  None (edit)
Description Denis Leroy 2008-10-10 06:01:14 EDT
Created attachment 319998 [details]
GDM stack trace

Was browsing the web when deskstop session crashed and found myself back at the GDM screen login.

Looking at /var/log/messages, there is a gdm trace in there. Trace is attached. I've since installed the debuginfo packages. If this happens again, I'll update the trace.
Comment 1 Denis Leroy 2008-10-10 06:02:29 EDT
This is with rawhide + latest updates.
Comment 2 Denis Leroy 2008-10-10 07:57:16 EDT
Created attachment 320007 [details]
GDM trace

Happened again (3rd time today). This is clearly caused by one of today's updates. One important clue: Notice the first line of the trace attached :

pulseaudio[5647]: cpulimit.c: Recevied request to terminate due to CPU overload.

This line was there in the previous trace, but I edited it out. Again I was using the web browser, andthere was a flash applet with soudn enabeld. Sound suddenly stopped, which must correspond to the overload line) as PA exited. 10 seconds later, 30 seconds later the enter desktop crashes and I'm back at gdm (i.e. gdm crash). The exact same thing happened in the previous crash occurrences.
Comment 3 Denis Leroy 2008-10-10 09:45:10 EDT
Seems to be a gnome-session bug, and is fixed with latest 
gnome-session-2.24.0-8.fc10.i386
Comment 4 Ray Strode [halfline] 2008-10-10 11:11:01 EDT
So for some reason we had a rawhide compose at 9:45 at night and then one at 9:45 in the morning...

Note You need to log in before you can comment on or make changes to this bug.