This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 466499 - RFE: yum install ./pkg*.rpm shouldn't install packages obsoleted by another package (rpm too)
RFE: yum install ./pkg*.rpm shouldn't install packages obsoleted by another p...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
Karel Srot
: FutureFeature
Depends On: 461898
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 12:02 EDT by James Antill
Modified: 2010-11-10 17:00 EST (History)
7 users (show)

See Also:
Fixed In Version: yum-3.2.27-7.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 17:00:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 1 Bill Nottingham 2008-10-10 14:10:56 EDT
If you change this in RPM, it can still cause gotchas with yum under the following scenario:

- A obsoletes B
- you have neither installed
- you install B
- upgrade then pulls in A

So, I'm not sure the simple fix here helps, but a complex fix that doesn't allow installing B in the situation above won't be applicable to RPM, since it doesn't deal at the repository level.
Comment 2 John W. Lockhart 2008-10-10 14:31:39 EDT
Why is the scenario in Comment 1 a problem?  It's exactly what you'd get if B were in a channel, and then A was released.  Packages that obsolete one another are always worth an extra few doses of caution, and why things like --exclude exist.  Correct?  or am I missing something?
Comment 3 James Antill 2008-10-10 14:40:43 EDT
Yeh, I think that's fine ... as long as rpm doesn't allow both to be installed I'm fine ... even if it allows you to do: rpm -e A && rpm -ivh B ... that's fine, yum can deal with the result.
Comment 4 RHEL Product and Program Management 2009-06-15 17:02:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 James Antill 2010-05-20 15:48:06 EDT
On the yum side, if obsoletes processing is turn on we now look at that. So this is "fixed" I guess.
Comment 9 releng-rhel@redhat.com 2010-11-10 17:00:24 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.