Bug 466509 - When prompted for a passphrase after a failure to connect, it's in hex and not the original text you entered
When prompted for a passphrase after a failure to connect, it's in hex and no...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: NetworkManager (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Dan Williams
desktop-bugs@redhat.com
: Desktop, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 12:51 EDT by Suzanne Hillman
Modified: 2009-09-02 07:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
when NetworkManager fails to connect to a wifi network, it re-prompts the user for the passphrase for that network. Previously, NetworkManager did not retain the original text of the passphrase entered by the user. Therefore, when users selected the "Show password" option so that they could see what they had typed after a failed connection attempt, NetworkManager displayed the passphrase in hexadecimal form. NetworkManager now retains the original text of the passphrase and displays the original passphrase instead of a hexadecimal string when the user selects the "Show password" option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:54:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suzanne Hillman 2008-10-10 12:51:43 EDT
Description of problem:
When prompted for a passphrase after a failure to connect, it's in hex and not the original text you entered. This makes it a bit confusing to tell if you mistyped it the first time, or something else is going on.

Version-Release number of selected component (if applicable):
NM-0.7.0-0.11.svn4133.el5

How reproducible:
Always

Steps to Reproduce:
1. Enter an incorrect passphrase for a wireless access point, with "Show password" checked so you can see what you're doing.

Actual results:
It'll prompt you again, but the passphrase will be hex, not your original string, so you have to retype the whole thing. (again, check 'Show Password')

Expected results:
Prompt should contain what you typed the first time, so you can tell if you made a mistake or if something else is going on.

Additional info:
No idea if this is a regression; I can't recall, and it was not something I thought to note in previous releases as working or not.
Comment 6 Dan Williams 2008-10-23 09:39:03 EDT
I can give this a shot this weekend perhaps.  It's not a small fix though.
Comment 7 Dan Williams 2008-11-12 17:13:13 EST
Punting to 5.4; it's a cosmetic regression, not a functional regression, and is too invasive to fix at this point in time.
Comment 8 RHEL Product and Program Management 2008-11-12 17:30:31 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.
Comment 9 Dan Williams 2009-05-09 23:49:13 EDT
fixed upstream in commits:

NM:

f3c9887472ef6d773aeabd0bb7fcf102cf725398 (0.7.x)
07cc26d5fc3df0ed47b4bb993ce9a0d4f0008876 (master)

applet:

1009da18d3e8fb9a86a01b43d27bd5cfc3a46336 (0.7.x)
e5fd1d53484aa182ca1ddaf602d4df700c29722f (0.7.x)
d9c45bfcf9db522c1724097341016cfca4e2fb78 (master)
574977f56fffa5725a7418ab3247681a4c1fe47e (master)
Comment 10 Dan Williams 2009-05-10 00:25:35 EDT
nm-wifi-passphrase-not-hex-rh466509.patch
nm-applet-wifi-passphrase-not-hex-rh466509.patch
Comment 12 Ruediger Landmann 2009-05-24 22:12:21 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
when NetworkManager fails to connect to a wifi network, it re-prompts the user for the passphrase for that network. Previously, NetworkManager did not retain the original text of the passphrase entered by the user. Therefore, when users selected the "Show password" option so that they could see what they had typed after a failed connection attempt, NetworkManager displayed the passphrase in hexadecimal form. NetworkManager now retains the original text of the passphrase and displays the original passphrase instead of a hexadecimal string when the user selects the "Show password" option.
Comment 13 Zack Cerza 2009-06-15 13:06:42 EDT
Verified on NetworkManager-0.7.0-7.el5.{i386,x86_64}.
Comment 15 errata-xmlrpc 2009-09-02 07:54:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1389.html

Note You need to log in before you can comment on or make changes to this bug.