Bug 466511 - Kernel crash when using openswan
Kernel crash when using openswan
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 13:08 EDT by Marek Greško
Modified: 2008-10-23 21:55 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.26.6-79.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 12:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marek Greško 2008-10-10 13:08:38 EDT
Description of problem:
Oct 10 00:12:39 gw kernel: BUG: soft lockup - CPU#1 stuck for 61s! [pluto:3398]
Oct 10 00:12:39 gw kernel: Modules linked in: authenc xfrm4_mode_tunnel deflate zlib_deflate ctr twofish twofish_common camellia serpent blowfish cbc xcbc crypto_null crypto_blkcipher xfrm4_tunnel tunnel4 esp4 aead ah4 aes_i586 aes_generic des_generic sha256_generic af_key w83627hf hwmon_vid hwmon ip6t_LOG ip6t_REJECT ip6table_mangle ip6table_filter ip6_tables nf_conntrack_ipv6 ipv6 ipt_recent ipt_LOG xt_limit xt_mac ipt_REJECT xt_owner xt_state xt_DSCP xt_tcpudp xt_MARK xt_CONNMARK ipt_MASQUERADE xt_policy iptable_mangle iptable_nat iptable_filter ip_tables x_tables nf_nat_tftp nf_nat_snmp_basic nf_nat_pptp nf_nat_proto_gre nf_nat_amanda nf_nat_irc nf_nat_h323 nf_nat_sip nf_nat_ftp nf_conntrack_tftp nf_conntrack_proto_sctp nf_conntrack_pptp nf_conntrack_proto_gre nf_conntrack_netlink nfnetlink nf_nat nf_conntrack_ipv4 nf_conntrack_netbios_ns ts_kmp nf_conntrack_amanda nf_conntrack_irc nf_conntrack_h323 nf_conntrack_sip nf_conntrack_ftp nf_conntrack dm_mirror dm_log dm_mod ppdev snd_intel8x0 snd_ac97_codec a
Oct 10 00:12:39 gw kernel: c97_bus parport_pc floppy parport snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm e1000 firewire_ohci firewire_core 8139cp crc_itu_t snd_timer snd 8139too mii soundcore serio_raw snd_page_alloc sr_mod pcspkr joydev cdrom i2c_i801 i2c_core iTCO_wdt iTCO_vendor_support sg ata_generic pata_acpi ata_piix libata sd_mod scsi_mod ext3 jbd mbcache uhci_hcd ohci_hcd ehci_hcd [last unloaded: scsi_wait_scan]
Oct 10 00:12:39 gw kernel:
Oct 10 00:12:39 gw kernel: Pid: 3398, comm: pluto Not tainted (2.6.26.5-45.fc9.i686 #1)
Oct 10 00:12:39 gw kernel: EIP: 0060:[<c0630d84>] EFLAGS: 00000202 CPU: 1
Oct 10 00:12:39 gw kernel: EIP is at _spin_lock+0x13/0x19
Oct 10 00:12:39 gw kernel: EAX: dc41d1ac EBX: dc41d1ac ECX: 00000054 EDX: 0000a7a8
Oct 10 00:12:39 gw kernel: ESI: dc68fa00 EDI: dc41d180 EBP: dfbf6cfc ESP: dfbf6cfc
Oct 10 00:12:39 gw kernel: DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Oct 10 00:12:39 gw kernel: CR0: 8005003b CR2: 08210b1c CR3: 1ee87000 CR4: 000006d0
Oct 10 00:12:39 gw kernel: DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
Oct 10 00:12:39 gw kernel: DR6: ffff0ff0 DR7: 00000400
Oct 10 00:12:39 gw kernel: [<c05f793f>] udp_queue_rcv_skb+0xd0/0x229
Oct 10 00:12:39 gw kernel: [<c05b8c49>] release_sock+0x3c/0x88
Oct 10 00:12:39 gw kernel: [<c05f8917>] udp_sendmsg+0x41e/0x4d2
Oct 10 00:12:39 gw kernel: [<c05fd250>] inet_sendmsg+0x3b/0x48
Oct 10 00:12:39 gw kernel: [<c05b7119>] sock_sendmsg+0xde/0xf9
Oct 10 00:12:39 gw kernel: [<c043964f>] ? autoremove_wake_function+0x0/0x33
Oct 10 00:12:39 gw kernel: [<c05b79ad>] sys_sendto+0xa4/0xc3
Oct 10 00:12:39 gw kernel: [<c04fb7eb>] ? copy_to_user+0x3b/0x10a
Oct 10 00:12:39 gw kernel: [<c05b80f4>] sys_socketcall+0xfb/0x187
Oct 10 00:12:39 gw kernel: [<c0404c32>] syscall_call+0x7/0xb
Oct 10 00:12:39 gw kernel: =======================


Version-Release number of selected component (if applicable):
kernel-2.6.26.5-45.fc9


How reproducible:


Steps to Reproduce:
1. Install lastest kernel 2.6.26.5-45.fc9 (latest Fedora 8 kernel 2.6.26.5 has also this bug).
2. Configure openswan.
3. You will get kernel crash with the above on the logs in several hours or days.
  
Actual results:
Kernel crashes on machines with openswan configured.

Expected results:
Kernel does not crash.

Additional info:
I am not sure, but it looks like the slower machines crashes more frequently.
Comment 1 Chuck Ebbert 2008-10-13 14:42:41 EDT
Fixed in 2.6.26.6
Comment 2 Fedora Update System 2008-10-14 15:52:59 EDT
kernel-2.6.26.6-46.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-46.fc8
Comment 3 Fedora Update System 2008-10-14 16:02:40 EDT
kernel-2.6.26.6-71.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/kernel-2.6.26.6-71.fc9
Comment 4 Fedora Update System 2008-10-20 16:29:22 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-8929
Comment 5 Fedora Update System 2008-10-23 12:38:51 EDT
kernel-2.6.26.6-79.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.