Bug 466520 - Package versions in Satellite-5.3.0-RHEL[45]-re20080922.0 are not consistent
Package versions in Satellite-5.3.0-RHEL[45]-re20080922.0 are not consistent
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Release (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Steve Salevan
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2008-10-10 14:03 EDT by Milan Zázrivec
Modified: 2009-09-10 14:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:53:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zázrivec 2008-10-10 14:03:29 EDT
Package versions across latest Vader composes:
* Satellite-5.3.0-RHEL5-re20080922.0
* Satellite-5.3.0-RHEL4-re20080922.0

are not consistent. For example:
spacewalk-backend-0.2.5-1.el5.sw vs. spacewalk-backend-0.2.2-1.el4.sw
spacewalk-search-0.2.7-1.el5.sw vs. spacewalk-search-0.2.6-1.el4.sw

Supposedly this reflects the status of package builds in brew for
every distro, but current status makes the composes unusable for
testing purposes. Compose build should result into composes with consistent
package versions.
Comment 1 Devan Goodwin 2008-10-10 14:55:13 EDT
spacewalk-backend looks to be at 0.2.7 in git's sw-0.2 branch so rebuilt this package for both el4 and el5 and built into both Satellite 5.3 tags.

Rebuilt spacewalk-search 0.2.7 for el4 and built this for just RHEL 4 Satellite 5.3.
Comment 2 Milan Zázrivec 2008-10-10 16:48:48 EDT
Schema:
spacewalk-schema-0.3.2-1.el5 vs. spacewalk-schema-0.3.1-1.el4

I don't understand why is this package in the satellite compose
in the first place, but:
spacewalk-proxy-html-0.2-1.el5.sw vs. spacewalk-proxy-html-0.1-2.el4.sw
Comment 7 Steve Salevan 2009-02-02 11:27:39 EST
Checked versions of Satellite packages between RHEL4 and RHEL5 ISOs from re20090127.2 composes.  All versions were identical, as far as I could tell, particularly between the spacewalk search, schema, and config packages.  Moving to VERIFIED.
Comment 8 Michael Mráka 2009-08-11 08:26:35 EDT
Verified in stage -> RELEASE_PENDING.

http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=83896

** Packages in RHEL 4 and RHEL 5  have to have the same version-release (modulo %{dist})
** Satellite-5.3.0-RHEL4-re20090806.0/i386/i386 Satellite-5.3.0-RHEL5-re20090806.0/i386/i386
:: [   PASS   ] :: Running '/mnt/tests/CoreOS/RHN-Satellite/Compose/Sanity/general/compose_check.sh package_os_versions  Satellite-5.3.0-RHEL4-re20090806.0/i386/i386 Satellite-5.3.0-RHEL5-re20090806.0/i386/i386'
Comment 9 Brandon Perkins 2009-09-10 14:53:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.