Bug 466543 - Merkaartor fails to start
Merkaartor fails to start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: merkaartor (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sven Lankes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 16:00 EDT by Dylan R. Semler
Modified: 2008-10-10 17:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-10 17:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dylan R. Semler 2008-10-10 16:00:26 EDT
Description of problem:
Merkaartor fails to start.  When launching from the terminal, the following is printed before it crashes:

Object::connect: No such signal QWebPage::loadFinished(bool)
getting:  "qrc:/Html/ymap.html?WIDTH=512&HEIGHT=512&BBOX=0.000000,0.000000,180.000000,-85.051129" 
merkaartor: symbol lookup error: merkaartor: undefined symbol: _ZNK8QWebPage20networkAccessManagerEv

I believe the Object::connect error is not related as I think I've gotten that on working builds too.

Version-Release number of selected component (if applicable):
merkaartor.x86_64 0:0.11-2.fc9

How reproducible:
Always

Steps to Reproduce:
1. Launch Merkaartor from the terminal
2.
3.
  
Actual results:
Merkaartor crashes

Expected results:
Merkaartor opens normally

Additional info:
I have been going back and forth between the RPM and building merkaartor from source.  I'm not sure if having source libraries around is causing the problem.  I have make uninstalled, make distcleaned, rebooted, and run ldconfig between the last source build and installing the RPM.
Comment 1 Till Maas 2008-10-10 16:39:59 EDT
On i386 it runs without any problems on a fresh installation.

Please post the output of the following commands:
grep networkAccessManagerEv /usr/lib*/libQt*
rpm --verify qt-x11
which merkaartor

Which version of qt-x11 do you have installed? 

Does it help to move the configuration file away?
E.g. with:

mv ~/.config/BartVanhauwaert/Merkaartor.conf{,.bak}

I also see the Object::connect message with my working merkaartor.
Comment 2 Dylan R. Semler 2008-10-10 17:14:50 EDT
Well, after building and uninstalling from source, then installing the 0.11 rpm again, the rpm seems to be working.  I can no longer reproduce the crash.  Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.