Bug 466544 - pulseaudio package is missing dependencies (and other surprises)
pulseaudio package is missing dependencies (and other surprises)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 16:03 EDT by Michal Jaegermann
Modified: 2008-12-18 10:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 10:11:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-10-10 16:03:02 EDT
Description of problem:

With pulseaudio installed gnome-session attempts to run
/usr/bin/start-pulseaudio-x11 and gets the following error:

/usr/bin/start-pulseaudio-x11: line 26: /usr/bin/pactl: No such file or directory

The problem is that /usr/bin/pactl comes from
pulseaudio-utils package and nothing is forcing installing
that.  Apparently this does not make any real difference
anyway as the next thing one gets:

pulseaudio[4179]: module.c: Failed to open module "module-x11-publish": module-x11-publish.so: cannot open shared object file: No such file or directory

and 'module-x11-xsmp' does not seem to be around either.

BTW - another set pulseaudio caused errors looks like this:

I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root priviliges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
W: main.c: High-priority scheduling enabled in configuration but not allowed by
policy.
W: core-util.c: setpriority(): Permission denied

and errors, except of those prefixed with "I", disappear after
an account in question is added to 'pulse-rt' group.  Who is
responsible for such additions? A sysadmin?

Note that "priviliges" is misspelled. Thrice.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-2.fc10

How reproducible:
always
Comment 1 Lennart Poettering 2008-10-19 16:30:57 EDT
The lines prefixed with W: are just warnings. You can safely ignore them.

The "privilige" typos are now fixed upstream.
Comment 2 Mads Kiilerich 2008-11-11 19:27:40 EST
So, what is left here is:
/usr/bin/start-pulseaudio-x11 from pulseaudio has unfulfilled requirements:
- /usr/bin/pactl from pulseaudio-utils
- /usr/lib/pulse-0.9/modules/module-x11-xsmp.so and module-x11-publish.so from pulseaudio-module-x11

Perhaps subpackage content could/should be moved around?

(I can't figure out what starts start-pulseaudio-x11)
Comment 3 Sebastian Vahl 2008-11-13 06:57:24 EST
/usr/bin/pactl is also missing on the KDE live images. So either pulseaudio should require pulseaudio-utils or pactl should be moved to pulseaudio package.
Comment 4 Bug Zapper 2008-11-25 22:45:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Lennart Poettering 2008-12-18 10:11:39 EST
In CVS start-pulseaudio-x11 and the XDG .desktop file that starts it are now moved to the p-m-x11 package. That package also now requires pulseaudio-utils.

This should fix all reported problems.

This will be part of the next RPM version I will upload to rawhide and F10.

Note You need to log in before you can comment on or make changes to this bug.