Bug 466599 - gnome-display-properties multihead settings don't persist
gnome-display-properties multihead settings don't persist
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 22:46 EDT by Gordon Messmer
Modified: 2014-06-18 05:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 02:36:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
monitors.xml present during the problem. (2.52 KB, text/plain)
2008-10-11 16:22 EDT, Gordon Messmer
no flags Details
~/.xsession-errors (39.62 KB, text/plain)
2008-11-30 10:22 EST, Matěj Cepl
no flags Details
/var/log/messages (10.15 KB, text/plain)
2008-11-30 10:24 EST, Matěj Cepl
no flags Details

  None (edit)
Description Gordon Messmer 2008-10-10 22:46:47 EDT
Description of problem:
I'm using an ATI video card with dual output.  If I disable kernel modesetting in order to use xrandr for display positioning (see bug 466598), I'm able to reorder my displays using gnome-display-properties.  However, once I log out, the displays go back to mirroring each other.  When I log back in, they remain mirrored.

Version-Release number of selected component (if applicable):
control-center-2.24.0.1-5.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Disable kernel modesetting
2. start gnome-display-properties
3. uncheck "mirror screens" if it's checked
4. move one monitor to the left of the other
5. click apply
6. log out
  
Actual results:
The displays will return to their default mode of operation: mirroring each other.

Expected results:
The settings applied by gnome-display-properties should persist.
Comment 1 Ray Strode [halfline] 2008-10-11 12:27:46 EDT
can you attach your ~/.config/monitors.xml ?
Comment 2 Gordon Messmer 2008-10-11 16:22:47 EDT
Created attachment 320111 [details]
monitors.xml present during the problem.
Comment 3 Gordon Messmer 2008-10-11 16:24:30 EDT
I've attached the file that was present at the time.  It has three configuration blocks, the first of which refers to outputs which aren't present.
Comment 4 Bernie Innocenti 2008-11-17 22:13:12 EST
Maybe a duplicate of #163385?
Comment 5 Bug Zapper 2008-11-25 22:46:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Matěj Cepl 2008-11-30 10:22:22 EST
I don't know what's the problem, but gnome-settings-daemon doesn't start for me as well.
Comment 7 Matěj Cepl 2008-11-30 10:22:59 EST
Created attachment 325128 [details]
~/.xsession-errors
Comment 8 Matěj Cepl 2008-11-30 10:24:37 EST
Created attachment 325129 [details]
/var/log/messages
Comment 9 Bernie Innocenti 2008-12-21 06:01:48 EST
Now (F10) gnome-settings-daemon starts normally, but gnome-display-properties still does not work with my Intel GM45, while randr does.
Comment 10 Matěj Cepl 2008-12-22 04:03:52 EST
Actually for me g-s-d still doesn't run after suspend/resume cycle (gnome-settings-daemon-2.24.1-4.fc10.i386).
Comment 11 Matěj Cepl 2008-12-22 04:03:52 EST
Actually for me g-s-d still doesn't run after suspend/resume cycle.
Comment 12 Matěj Cepl 2008-12-22 06:29:38 EST
There is nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 13 Bernie Innocenti 2008-12-22 08:53:46 EST
Do you have acpid running?

Someone suggested it should be disabled because gnome-power-manager replaced it completely.
Comment 14 Matěj Cepl 2008-12-22 11:30:12 EST
[matej@viklef ~]$ pgrep -f -l acpid
91 kacpid
[matej@viklef ~]$ 

(kacpid is part of kernel)

Note You need to log in before you can comment on or make changes to this bug.