Bug 466611 - lang script do not setup unicode console correct (call of unicode_start/unicode_stop miss)
lang script do not setup unicode console correct (call of unicode_start/unico...
Status: CLOSED DUPLICATE of bug 458362
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-11 05:56 EDT by Sergei LITVINENKO
Modified: 2014-03-16 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 21:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei LITVINENKO 2008-10-11 05:56:49 EDT
Description of problem:

[sergeil@homedesk ~]$ cat /etc/sysconfig/i18n
LANG="ru_RU.UTF-8"
SYSFONT="latarcyrheb-sun16"

Missing call of unicode_start in /etc/profile.d/lang.* cause wrong charset in text console. Russian text console is not applicable in any case.

Version-Release number of selected component (if applicable):

initscripts-8.83-1.i386

How reproducible:

100%


Steps to Reproduce:
1. Set UTF8 russian locale
2. Boot in runlevel 3
3.
  
Actual results:
All russian subbols are not  readable

Expected results:
Correct russian symbols and borders in mc

Additional info:
Fix /etc/profile.d/lang.sh by restoring messing fragments (source is lang.sh from fedora-8) solve problem.
...
    if [ -n "$LANG" ]; then
      case $LANG in
        *.utf8*|*.UTF-8*)
        if [ "$TERM" = "linux" ]; then
            if [ "$consoletype" = "vt" ]; then
+                if [ -x /bin/unicode_start ] && /sbin/consoletype fg ; then
+                        for langfile in /etc/sysconfig/i18n $HOME/.i18n ; do
+                                [ -f $langfile ] && . $langfile
+                        done
+                        /bin/unicode_start $SYSFONT $SYSFONTACM
+                fi

                case $LANG in
                        ja*) LANG=en_US.UTF-8 ;;
                        ko*) LANG=en_US.UTF-8 ;;
                        si*) LANG=en_US.UTF-8 ;;
                        zh*) LANG=en_US.UTF-8 ;;
                        en_IN*) ;;
                        *_IN*) LANG=en_US.UTF-8 ;;
                esac
            fi
        fi

...

        if [ "$TERM" = "linux" ]; then
            if [ "$consoletype" = "vt" ]; then
                case $LANG in
                        ja*) LANG=en_US ;;
                        ko*) LANG=en_US ;;
                        si*) LANG=en_US ;;
                        zh*) LANG=en_US ;;
                        en_IN*) ;;
                        *_IN*) LANG=en_US ;;
                esac
+                [ -x /bin/unicode_stop ] && /sbin/consoletype fg && /bin/unicode_stop
            fi
        fi
Comment 1 Bill Nottingham 2008-10-13 21:14:07 EDT

*** This bug has been marked as a duplicate of bug 458362 ***

Note You need to log in before you can comment on or make changes to this bug.