Bug 466615 - HTML Export issues on both F9 and F10 + fixes provided
HTML Export issues on both F9 and F10 + fixes provided
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: planner (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-11 08:28 EDT by Chitlesh GOORAH
Modified: 2009-12-09 01:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 08:05:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2008-10-11 08:28:26 EDT
Description of problem:

I have some issues with the HTML export:

[#1] first, on firefox 3 (but not on FF2), the horizontal scroll bar for
the gantt diagram is outside the page range.
Example: http://chitlesh.fedorapeople.org/planner/FEL11_devel_timeline.html
I liked the horizontal scroll bar as it helps one to keep track of the
items on the "Name" column while scrolling. This is among the reasons
why I prefer HTML export over PDF export.

[#2] second, during export, the resources are not displayed correctly on
the output html page.
See the row "FEL10" on the above url.
The planner document :
http://chitlesh.fedorapeople.org/planner/FEL11_devel_timeline.planner


Version-Release number of selected component (if applicable):
planner-0.14.2-12.fc9.i386

How reproducible:
Everytime

Steps to Reproduce:
1. planner FEL11_devel_timeline.planner
2. File > Export > html
3.
  
Additional info:

both F9 and F10 planner versions are affected by [#1].
The solution to this will be to replace all the stylesheets of the 0.14.3 version by those:
http://svn.gnome.org/svn/planner/trunk/data/stylesheets/html1_css.xsl
http://svn.gnome.org/svn/planner/trunk/data/stylesheets/html1_css_ie.xsl
http://svn.gnome.org/svn/planner/trunk/data/stylesheets/html1_css_ie7.xsl
http://svn.gnome.org/svn/planner/trunk/data/stylesheets/html1_gantt.xsl
http://svn.gnome.org/svn/planner/trunk/data/stylesheets/html1_resources.xsl
http://svn.gnome.org/svn/planner/trunk/data/stylesheets/html1_tasks.xsl
http://svn.gnome.org/svn/planner/trunk/data/stylesheets/planner2html.xsl

Only F9 is affected by [#2]. The solution to this to push planner-0.14.3 with the above fix to the F9 repository.



This email explains in more details: http://mail.gnome.org/archives/planner-list/2008-October/msg00004.html
Comment 1 Caolan McNamara 2008-10-12 17:55:18 EDT
0.14.3 is in F-10, and 0.14.2 in F-9. I don't really feel that planner is a sufficiently vital piece of the desktop for me to invest time backporting the fix-of-the-day to F-9 and bumping it to 0.14.3. But if you want to extract out a diff against 0.14.3 for this issue I could put it into F-10 for you.
Comment 2 Chitlesh GOORAH 2008-10-13 06:15:20 EDT
Well, is it that hard to provide a proper and neat application for normal usage ?

All you need to do is 
- diff the 0.14.3 and the xsl stated on comment #1
- commit and build the rpms for F-9 and F-10

Planner is a vital element for "project management". Please don't underestimate your own package.
Comment 4 Caolan McNamara 2008-10-14 08:05:23 EDT
Backported to F-10 and pushed as 0.14.3-5, I'm going to punt on a rebase of planner in F-9

Note You need to log in before you can comment on or make changes to this bug.