Bug 466618 - help-browser segmentation fault.
help-browser segmentation fault.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: WebKit (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-11 09:05 EDT by sangu
Modified: 2008-10-24 20:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0.0-0.15.svn37790.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 20:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-10-11 09:05:27 EDT
Description of problem:
Click link on help, help-browser segmentation fault.
$ gimp
/usr/lib/gimp/2.0/plug-ins/help-browser: fatal error: Segmentation fault

Version-Release number of selected component (if applicable):
2.6.1-1.fc10

How reproducible:
always

Steps to Reproduce:
1. Launch gimp
2. Click Help ->  Help
3. click link on help-browser
  
Actual results:


Expected results:


Additional info:
1.0.0-0.13.svn34655.fc10
Comment 1 sangu 2008-10-11 09:28:40 EDT
WebKit-gtk-1.0.0-0.13.svn34655.fc10.i386

$ gimp --stack-trace-mode=query
/usr/lib/gimp/2.0/plug-ins/help-browser: fatal error: segmentaion fault
/usr/lib/gimp/2.0/plug-ins/help-browser (pid:1177): [E]xit, [H]alt, show [S]tack trace or [P]roceed: S
#0  0x00132416 in __kernel_vsyscall ()
#1  0x057fd053 in __waitpid_nocancel () from /lib/libc.so.6
#2  0x04c1be15 in IA__g_on_error_stack_trace (
#3  0x04c1c015 in IA__g_on_error_query (
#4  0x0028b9dc in gimp_plugin_sigfatal_handler (sig_num=11) at gimp.c:1582
#5  <signal handler called>
#6  0x057d53c3 in strlen () from /lib/libc.so.6
#7  0x0068eec5 in WebCore::String::fromUTF8 (string=0x0)
#8  0x003ade42 in webkit_web_history_item_set_alternate_title (
#9  0x003adf87 in webkit_web_history_item_set_property (object=0x85a52c8, 
#10 0x03f70a51 in object_set_property () at gobject.c:938
#11 g_object_constructor (type=140965520, n_construct_properties=0, 
#12 0x03f71196 in IA__g_object_newv (object_type=140965520, n_parameters=0, 
#13 0x03f71d67 in IA__g_object_new_valist (object_type=140965520, 
#14 0x03f71ede in IA__g_object_new (object_type=140965520, 
#15 0x003ad8f4 in webkit_web_history_item_new_with_core_item (item=0xb70ffb60)
#16 0x003aaee6 in webkit_web_back_forward_list_get_back_list_with_limit (
#17 0x0804e312 in update_actions () at dialog.c:955
#18 0x003beac3 in webkit_marshal_VOID__OBJECT_STRING (closure=0x8601b18, 
#19 0x03f6b1db in IA__g_closure_invoke (closure=0x8601b18, return_value=0x0, 
#20 0x03f81625 in signal_emit_unlocked_R (node=0x85f9e98, detail=0, 
#21 0x03f82d3c in IA__g_signal_emit_valist (instance=0x85e6168, signal_id=201, 
#22 0x03f8305d in IA__g_signal_emit_by_name (instance=0x85e6168, 
#23 0x003bd1ca in WebKit::FrameLoaderClient::dispatchDidReceiveTitle (
#24 0x005d198e in WebCore::FrameLoader::didChangeTitle (this=0xb70bb6a4, 
#25 0x005c4e55 in WebCore::DocumentLoader::setTitle (this=0xb70d0000, 
#26 0x005cbf37 in WebCore::FrameLoader::setTitle (this=0xb70bb6a4, 
#27 0x0046a10b in WebCore::Document::updateTitle (this=0xb70c0000)
#28 0x00477ebb in WebCore::Document::setTitle (this=0xb70c0000, 
#29 0x005a150a in WebCore::HTMLTitleElement::childrenChanged (this=0xb70afc30, 
#30 0x00463e96 in WebCore::ContainerNode::addChild (this=0xb70afc30, newChild=
#31 0x0058ce1b in WebCore::HTMLParser::insertNode (this=0xb71858f8, 
#32 0x0058d55a in WebCore::HTMLParser::parseToken (this=0xb71858f8, 
#33 0x005a50f6 in WebCore::HTMLTokenizer::processToken (this=0xb7101400)
#34 0x005a69d4 in WebCore::HTMLTokenizer::parseSpecial (this=0xb7101400, 
#35 0x005a8d8f in WebCore::HTMLTokenizer::parseTag (this=0xb7101400, 
#36 0x005a967b in WebCore::HTMLTokenizer::write (this=0xb7101400, 
#37 0x005d3774 in WebCore::FrameLoader::write (this=0xb70bb6a4, 
#38 0x005d3b77 in WebCore::FrameLoader::addData (this=0xb70bb6a4, 
#39 0x003bc6b7 in WebKit::FrameLoaderClient::committedLoad (this=0xb70b8f80, 
#40 0x005cc8d7 in WebCore::FrameLoader::committedLoad (this=0xb70bb6a4, 
#41 0x005c471f in WebCore::DocumentLoader::commitLoad (this=0xb70d0000, 
#42 0x005ccc35 in WebCore::FrameLoader::receivedData (this=0xb70bb6a4, 
#43 0x005f1f86 in WebCore::MainResourceLoader::addData (this=0xb70cf000, 
#44 0x005f941c in WebCore::ResourceLoader::didReceiveData (this=0xb70cf000, 
#45 0x005f2220 in WebCore::MainResourceLoader::didReceiveData (
#46 0x005f8fc8 in WebCore::ResourceLoader::didReceiveData (this=0xb70cf000, 
#47 0x00767693 in writeCallback (ptr=0x87a3c44, size=1, nmemb=16383, 
#48 0x04015645 in Curl_client_write (conn=0x866f300, 
#49 0x0400b072 in file_do (conn=0x866f300, done=0xbfc20aa8) at file.c:554
#50 0x0401ef90 in Curl_do (connp=0x87e5e54, done=0xbfc20aa8) at url.c:4578
#51 0x0402ed1d in multi_runsingle (multi=0x86916d8, easy=0x87e5e48)
#52 0x0402f069 in curl_multi_perform (multi_handle=0x86916d8, 
#53 0x0076a57a in WebCore::ResourceHandleManager::downloadTimerCallback (
#54 0x0076ab31 in WebCore::Timer<WebCore::ResourceHandleManager>::fired (
#55 0x0069c71a in WebCore::TimerBase::fireTimers (fireTime=1223731467.7231081, 
#56 0x0069c7e7 in WebCore::TimerBase::sharedTimerFired ()
#57 0x0091b0ce in timeout_cb () at WebCore/platform/gtk/SharedTimerGtk.cpp:48
#58 0x04c3f2e1 in g_idle_dispatch (source=0x85e5ec0, callback=0, user_data=0x0)
#59 0x04c41218 in g_main_dispatch () at gmain.c:2142
#60 IA__g_main_context_dispatch (context=0x852ac00) at gmain.c:2695
#61 0x04c448c3 in g_main_context_iterate (context=0x852ac00, block=1, 
#62 0x04c44de2 in IA__g_main_loop_run (loop=0x8605408) at gmain.c:2984
#63 0x00e9d379 in IA__gtk_main () at gtkmain.c:1200
#64 0x0804d3ad in run (name=0x852ad10 "extension-gimp-help-browser", 
#65 0x0028b583 in gimp_proc_run () at gimp.c:1894
#66 gimp_loop () at gimp.c:1728
#67 gimp_main (info=0x8051b20, argc=6, argv=0xbfc21114) at gimp.c:464
#68 0x0804d6ea in main (argc=Cannot access memory at address 0x0
Comment 2 Nils Philippsen 2008-10-13 07:11:03 EDT
I assume this is a problem in WebKit because when I used it with a current-git WebKit library, it works. Changing component to WebKit.

Sangu, in the meantime you can configure GIMP to use your normal web browser for online documentation in the GIMP preferences: Edit -> Preferences -> Help System -> Help Browser.
Comment 3 Peter Gordon 2008-10-24 15:08:39 EDT
Thanks for the bug report!

I've pushed an updated WebKit snapshot to rawhide this morning (SVN 37790). Does the help browser still crash after updating to this?
Comment 4 sangu 2008-10-24 20:28:59 EDT
Fixed! 

Thanks!

Note You need to log in before you can comment on or make changes to this bug.