Bug 466620 - JTextPane has bad height (incorrect preferredSize)
JTextPane has bad height (incorrect preferredSize)
Status: CLOSED DUPLICATE of bug 452573
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-11 09:44 EDT by Joel Uckelman
Modified: 2009-01-09 14:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 14:09:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a test case which shows the problem (1.38 KB, text/x-java)
2008-10-11 09:44 EDT, Joel Uckelman
no flags Details
test run on Sun's JVM (19.25 KB, image/png)
2008-10-11 09:48 EDT, Joel Uckelman
no flags Details
test run on OpenJDK JVM (20.61 KB, image/png)
2008-10-11 09:50 EDT, Joel Uckelman
no flags Details

  None (edit)
Description Joel Uckelman 2008-10-11 09:44:00 EDT
Created attachment 320094 [details]
a test case which shows the problem

Description of problem:

Fix the width of a JTextPane, set it to have whatever height it prefers given that width, and put it into a JDialog which is then packed. Using OpenJDK, the JTextPane ends up with a lot of extra empty space below the text. This works properly with Sun Java 1.6.0_07-b06. I've attached a minimal example program which exhibits the problem.


Version-Release number of selected component (if applicable):

java-1.6.0-openjdk-1.6.0.0-0.20.b11.fc10.x86_64


How reproducible:

Always.

Steps to Reproduce:
1. javac Test.java
2. java Test
  
Actual results:

There is extra space below the text.


Expected results:

The dialog should be tight around the bottom of the text.


Additional info:

Note that this is a regression from Sun's Java.
Comment 1 Joel Uckelman 2008-10-11 09:48:26 EDT
Created attachment 320095 [details]
test run on Sun's JVM

This image is from running the test case in Sun's JVM. The JTextPane appears to have the correct size.
Comment 2 Joel Uckelman 2008-10-11 09:50:29 EDT
Created attachment 320096 [details]
test run on OpenJDK JVM

This image is from running the test case in the OpenJDK JVM. The JTextPane has a large empty area at the bottom.
Comment 3 Joel Uckelman 2008-10-11 11:39:55 EDT
The amount of blank space at the bottom of the JTextPane seems to depend on the size of the font used. E.g., add this line to the test case before setting the width of the JTextPane:

    tp.setFont(tp.getFont().deriveFont(tp.getFont().getSize()*2.0f));

The result is that the font size is doubled and the height of the blank space is roughly tripled (from 30px to about 85px).
Comment 4 Bug Zapper 2008-11-25 22:47:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Joel Uckelman 2008-11-29 09:52:14 EST
This problem still exists in java-1.6.0-openjdk-1.6.0.0-6.b12.fc10.x86_64 from Fedora 10.
Comment 6 Omair Majid 2009-01-09 14:09:30 EST
This is caused by a bug in the calculation of the window size. Fixed upstream:
http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2009-January/004455.html

*** This bug has been marked as a duplicate of bug 452573 ***

Note You need to log in before you can comment on or make changes to this bug.