Bug 466623 - when rotated, mouse cursor disappears near right edge
when rotated, mouse cursor disappears near right edge
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-11 11:30 EDT by Adam Goode
Modified: 2009-10-20 06:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 06:32:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot dmesg (47.57 KB, text/plain)
2009-05-06 19:34 EDT, Adam Goode
no flags Details
dmesg with X running (122.38 KB, text/plain)
2009-05-06 19:34 EDT, Adam Goode
no flags Details
xorg log (68.38 KB, text/plain)
2009-05-06 19:35 EDT, Adam Goode
no flags Details

  None (edit)
Description Adam Goode 2008-10-11 11:30:55 EDT
Description of problem:
When my 1680x1050 display is rotated left with r300 and kernel modesetting, the mouse cursor is invisible near the right edge of the display.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.1-10.fc10.x86_64
xorg-x11-drv-ati-6.9.0-25.fc10.x86_64
kernel-2.6.27-1.fc10.x86_64


How reproducible:
Always.


Steps to Reproduce:
1. xrandr --output DVI-0 --rotate left
  
Additional info:
ATI Technologies Inc RV370 5B64 [FireGL V3100 (PCIE)] rev 128
Comment 1 Matěj Cepl 2008-10-12 18:13:23 EDT

*** This bug has been marked as a duplicate of bug 464853 ***
Comment 2 Adam Goode 2008-10-12 20:25:57 EDT
This is not a duplicate of 464853, that bug refers to the contents of windows, and was fixed recently. This is a new bug that cropped up after the redraw bug was fixed. It has nothing to do with the contents of windows, it is more like the other bug where the mouse cursor would disappear at the top of the screen.
Comment 3 Bug Zapper 2008-11-25 22:47:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 François Cami 2009-05-06 06:49:43 EDT
Adam,

Please post the output of :

rpm -q kernel xorg-x11-drv-ati mesa-libGL mesa-dri-drivers libdrm

Please also add your dmesg output with drm.debug=1 in the kernel command line, and /var/log/Xorg.0.log as uncompressed text/plain attachements to this bug.

Thanks in advance

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Goode 2009-05-06 19:34:22 EDT
Created attachment 342748 [details]
boot dmesg
Comment 6 Adam Goode 2009-05-06 19:34:54 EDT
Created attachment 342749 [details]
dmesg with X running
Comment 7 Adam Goode 2009-05-06 19:35:42 EDT
Created attachment 342750 [details]
xorg log
Comment 8 Adam Goode 2009-05-06 19:36:44 EDT
$ rpm -q kernel xorg-x11-drv-ati mesa-libGL mesa-dri-drivers libdrm
kernel-2.6.29.1-102.fc11.x86_64
kernel-2.6.29.1-111.fc11.x86_64
kernel-2.6.29.2-126.fc11.x86_64
xorg-x11-drv-ati-6.12.2-7.fc11.x86_64
mesa-libGL-7.5-0.9.fc11.x86_64
mesa-libGL-7.5-0.9.fc11.i586
mesa-dri-drivers-7.5-0.9.fc11.x86_64
mesa-dri-drivers-7.5-0.9.fc11.i586
libdrm-2.4.6-6.fc11.x86_64
libdrm-2.4.6-6.fc11.i586
Comment 9 Bug Zapper 2009-06-09 05:46:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Adam Goode 2009-08-10 11:47:44 EDT
This appears to be fixed in rawhide.
Comment 11 Matěj Cepl 2009-08-10 16:34:03 EDT
(In reply to comment #10)
> This appears to be fixed in rawhide.  

Thanks for letting us know.
Comment 12 Adam Goode 2009-08-10 20:28:35 EDT
Curiously, the problem isn't 100% fixed. If the cursor is near the right edge of the screen, and the cursor icon changes, the cursor disappears until it moves. Practically speaking, it's ok, but there is still a weird bug there near the edge of the screen.
Comment 13 Matěj Cepl 2009-08-11 04:23:10 EDT
(In reply to comment #12)
> Curiously, the problem isn't 100% fixed. If the cursor is near the right edge
> of the screen, and the cursor icon changes, the cursor disappears until it
> moves. Practically speaking, it's ok, but there is still a weird bug there near
> the edge of the screen.  

Isn't it bug 510125? I have still my deep suspicion that there might be some relationship between these two.
Comment 14 Adam Goode 2009-08-11 15:13:06 EDT
No, this has nothing to do with bug 510125. That bug is about when the mouse cursor goes into a region that is not covered by a monitor. This happens because of randr, and has always happened with X, as far as I know.

This bug is when the mouse is near the right hand side of a rotated screen using KMS on radeon.

Also, before the new somewhat fixed behavior, the mouse cursor would be fine up to close to the edge of the monitor, then get more and more corrupted the closer it got to the edge, then finally disappear. You could still click the mouse, you just could not see the cursor.
Comment 15 Matěj Cepl 2009-08-11 18:20:36 EDT
OK, so reopening.
Comment 16 Adam Goode 2009-10-09 08:03:12 EDT
xorg-x11-drv-ati-6.13.0-0.10.20091006git457646d73.fc12.x86_64 seems to have fixed this, so far.
Comment 17 Jérôme Glisse 2009-10-20 06:32:00 EDT
I am closing this one reopen if you experience the issue again.

Note You need to log in before you can comment on or make changes to this bug.