Bug 466627 - some non-functional keys Arabic keyboard layout
some non-functional keys Arabic keyboard layout
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F10Target F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-11 13:51 EDT by Muayyad Alsadi
Modified: 2014-06-18 05:10 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.5-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-23 18:13:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/usr/share/X11/xkb/symbols/ara and /usr/share/X11/locale/en_US.UTF-8/Compose (37.18 KB, application/x-bzip2)
2008-10-11 13:51 EDT, Muayyad Alsadi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 574581 None None None Never
FreeDesktop.org 19291 None None None Never

  None (edit)
Description Muayyad Alsadi 2008-10-11 13:51:09 EDT
Created attachment 320100 [details]
/usr/share/X11/xkb/symbols/ara and /usr/share/X11/locale/en_US.UTF-8/Compose 

Description of problem:
because X can generate only one character per key the key لا is mapped to
U+FEFB ARABIC LIGATURE LAM WITH ALEF ISOLATED FORM

but it should be mapped to the sequence U+0644 U+0627
U+0644 ARABIC LETTER LAM followed by U+0627 ARABIC LETTER ALEF

when this problem noticed they disabled the key completely
(map it to null)

http://lists.arabeyes.org/archives/developer/2008/May/msg00013.html

Version-Release number of selected component (if applicable):
libX11-1.1.4-1.fc9.i386

How reproducible:
always

Additional info:
solution can be found here
http://lists.arabeyes.org/archives/developer/2008/June/msg00001.html
http://mail.gnome.org/archives/gnome-i18n/2008-June/msg00030.html

it means that the files
/usr/share/X11/xkb/symbols/ara
/usr/share/X11/locale/en_US.UTF-8/Compose 
must be replaced (no matter one uses Arabic keyboard or not)

and a file called /etc/X11/xinit/xinitrc.d/xim.sh should contain
export GTK_IM_MODULE="xim"
export QT_IM_MODULE="xim"

I'm not sure if this last step affects other languages
so I'm not requesting it, the first step will be enough
and we will tell Arabic users to create it themselves
(not creating the second file has no side effects)
Comment 1 Bug Zapper 2008-11-25 22:47:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Update System 2009-03-01 18:24:50 EST
libX11-1.1.5-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/libX11-1.1.5-1.fc10
Comment 3 Fedora Update System 2009-03-01 18:36:23 EST
xkeyboard-config-1.4-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xkeyboard-config-1.4-7.fc10
Comment 4 Muayyad Alsadi 2009-03-01 18:39:44 EST
is libX11-1.1.5-1.fc10 after or before Sergey's commit in the upstream ?

>Sergey committed the change to symbols/ara earlier this month
>with commit c3b2fd97444f47e726b7916dd1a3ce04ada2d88d.
Comment 5 Peter Hutterer 2009-03-01 19:00:14 EST
I patched xkeyboard-config with sergey's commit, but you need both libX11-1.1.5 and the new xkeyboard-config (AFAIU anyway).
Comment 6 Fedora Update System 2009-03-02 12:02:10 EST
xkeyboard-config-1.4-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xkeyboard-config'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2234
Comment 7 Muayyad Alsadi 2009-03-02 16:30:41 EST
the xkeyboard-config portion of the problem is solved I guess
ie. when b is pressed in Arabic layout I got the unicode char U+FEFB  ﻻ

but this is another bug as it should be ل followed by ا

maybe that part will be solved when I update to the other libX11-1.1.5-1.fc10
but that can't be done because version number of xkeyboard-config should match that of libX11

so please don't push it to stable until it's fixed in both
-----------
reasoning:
having one but not the other will generate U+FEFB not the sequence ل followed by ا
Comment 8 Peter Hutterer 2009-03-02 16:33:35 EST
(In reply to comment #7)
> maybe that part will be solved when I update to the other libX11-1.1.5-1.fc10
> but that can't be done because version number of xkeyboard-config should match
> that of libX11

well, you're already running libX11 1.1 and xkeyboard-config 1.4. so no - the versions don't need to match, you can just upgrade.
Comment 9 Muayyad Alsadi 2009-03-02 16:52:40 EST
yes, I installed both and it works [in the first time it was a missing -devel that I forgot lead me to break the dependency]

but of course that required this like
cat <<EOF >/etc/X11/xinit/xinitrc.d/xim.sh
export GTK_IM_MODULE="xim"
export QT_IM_MODULE="xim
EOF

how can we tell users to do that step [I'm told setting xim as default is not good for other people]
Comment 10 Fedora Update System 2009-03-04 11:24:45 EST
libX11-1.1.5-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libX11'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2307
Comment 11 Muayyad Alsadi 2009-03-04 11:39:33 EST
I already use that from comment #2

[alsadi@pc1 ~]$ rpm -q libX11
libX11-1.1.5-1.fc10.i386

how to tell people about #9
Comment 12 Peter Hutterer 2009-03-04 21:19:30 EST
the update system message is automatic, there's more of those to come when the update gets pushed to stable.

As for your Comment #9 - I don't actually know. It's probably best if you ask on fedora-devel, I'm sure there's someone that knows the best procedure.
Comment 13 Muayyad Alsadi 2009-03-08 16:00:50 EDT
a similar problem exists on GTK+ on windows I'm not sure how is this related to the topic, it could be something in gdk

the upstream bug for that is added

> I don't actually know. It's probably best if you ask on fedora-devel
thanks I'll take your advice
Comment 14 Fedora Update System 2009-03-18 15:10:08 EDT
xkeyboard-config-1.4-7.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-03-23 11:54:32 EDT
libX11-1.1.5-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Muayyad Alsadi 2009-03-23 14:44:14 EDT
I'm already using them and the problem is not solved

[alsadi@pc1 ~]$ rpm -q libX11 xkeyboard-config
libX11-1.1.5-1.fc10.i386
xkeyboard-config-1.4-7.fc10.noarch
Comment 17 Peter Hutterer 2009-03-23 17:45:00 EDT
just confirming: the remaining issue is what you mentioned in Comment #9?
Comment 18 Muayyad Alsadi 2009-03-23 18:13:54 EDT
I guess comment #9 is not a critical thing, mentioning it in release notes will be sufficient
--
sorry, I was confused with with this one

https://bugzilla.redhat.com/show_bug.cgi?id=487583

that bug is not yet solved
I ment to keep that one opened not this one

Note You need to log in before you can comment on or make changes to this bug.