This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 466650 - geoclue library linking problems
geoclue library linking problems
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: geoclue (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopTarget
  Show dependency treegraph
 
Reported: 2008-10-12 00:35 EDT by Matthias Clasen
Modified: 2009-04-24 15:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.11.1.1-0.1.20090310git3a31d26.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 16:27:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-10-12 00:35:27 EDT
prelink complains

/usr/sbin/prelink: Warning: /usr/lib/libgeoclue.so.0.0.0 has undefined non-weak symbols

And, in fact, ldd shows:

undefined symbol: g_cclosure_marshal_VOID__POINTER      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_free        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_cclosure_marshal_VOID__INT  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_str_hash    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_str_equal   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_free        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_memdup      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_interface_peek (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlBufferAdd  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_param_spec_string   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_proxy_call     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_get_boxed     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlXPathFreeObject    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_method_return  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlXPathRegisterNs    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_intern_static_string        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_type_get_map   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_dup_string    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_hash_table_destroy  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlXPathCastNodeSetToString   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlBufferFree (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlXPathCastNodeSetToNumber   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlURIEscapeStr       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_error_new   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_signal_emit (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_object_unref        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_strdup      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_set_boolean   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_get_double    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_list_foreach        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_hash_table_insert   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_list_free   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_set_int       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_printerr    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_object_class_install_property       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_malloc      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_proxy_new_for_name     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_object_register_marshaller     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_hash_table_remove   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_bus_get        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_peek_pointer  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlNanoHTTPClose      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_type_struct_set        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_connection_register_g_object   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_assertion_message_expr      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_object_new  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlXPathNewContext    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_object_ref  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_proxy_connect_signal   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_strdup_printf       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_proxy_end_call (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_check_class_cast       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_object_add_weak_pointer     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_hash_table_size     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_proxy_add_signal       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_hash_table_new_full (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_hash_table_foreach  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_once_init_enter_impl        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_set_double    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_object_type_install_info       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_return_if_fail_warning      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_register_static        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlBufferContent      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_quark_from_static_string    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_signal_new  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_object_path_get_g_type (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_check_instance_is_a    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlStrndup    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlBufferLength       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_proxy_begin_call       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_name   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlNanoHTTPRead       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_instance_get_private   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_check_instance_cast    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlXPathFreeContext   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlXPathEvalExpression        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_register_static_simple (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_hash_table_lookup   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlBufferCreate       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_take_boxed    (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_malloc0     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_init  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_list_prepend        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlNanoHTTPMethod     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_type_specialized_construct     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlNanoHTTPInit       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_error_free  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_array_get_nth (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_value_get_int       (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_boxed_free  (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_once_init_leave     (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: xmlParseDoc   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_add_interface_static   (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_type_get_struct        (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_class_add_private      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_type_class_peek_parent      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: dbus_g_method_get_sender      (/usr/lib/libgeoclue.so.0.0.0)
undefined symbol: g_log (/usr/lib/libgeoclue.so.0.0.0)
        linux-gate.so.1 =>  (0x00110000)
        libc.so.6 => /lib/libc.so.6 (0x00b12000)
        /lib/ld-linux.so.2 (0x00aee000)

It looks like libgeoclue should at least be linked against glib, gobject, dbus, libxml
Comment 1 Peter Robinson 2008-10-12 05:29:20 EDT
Reported upstream to start with, we'll see if they respond. Otherwise I'll try and workout what needs to be done to fix it downstream. A quick google based on your comments looks like it might be just in the ways its linked so might be just some auto/configure/make foo?
Comment 2 Matthias Clasen 2008-10-12 10:23:40 EDT
The missing libraries need to be added to some _LIBADD variable in some Makefile.am, probably coming from some pkg-config --libs call in configure...
Comment 3 Bug Zapper 2008-11-25 22:47:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Peter Robinson 2008-11-27 16:20:39 EST
This I think has been finally fixed upstream, I think there's going to be a new release shortly.... finally.
Comment 5 Peter Robinson 2009-03-10 13:21:38 EDT
I've got sick of waiting for upstream to push a new release for this so I've moved to a git snapshot. Version geoclue-0.11.1.1-0.1.20090310git3a31d26 should appear in the next rawhide.

AFAICT it looks to be fixed. If you can verify that it is I'll push an update out to stable as well.

[root@neo x86_64]# ldd /usr/lib64/libgeoclue.so.0.0.0
	linux-vdso.so.1 =>  (0x00007fff083fe000)
	libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x0000000000178000)
	libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x0000000000398000)
	libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00000000005d6000)
	libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x0000000000983000)
	libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x0000000000e98000)
	libc.so.6 => /lib64/libc.so.6 (0x0000000084aa5000)
	libnsl.so.1 => /lib64/libnsl.so.1 (0x00000000011f4000)
	libcap.so.2 => /lib64/libcap.so.2 (0x000000000140e000)
	libdl.so.2 => /lib64/libdl.so.2 (0x0000000001612000)
	libz.so.1 => /lib64/libz.so.1 (0x0000000001816000)
	libm.so.6 => /lib64/libm.so.6 (0x00000000318e1000)
	/lib64/ld-linux-x86-64.so.2 (0x00000035c6000000)

Koji build is:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1235117
Comment 6 Fedora Update System 2009-04-16 05:54:59 EDT
geoclue-0.11.1.1-0.1.20090310git3a31d26.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/geoclue-0.11.1.1-0.1.20090310git3a31d26.fc10
Comment 7 Fedora Update System 2009-04-16 05:55:04 EDT
geoclue-0.11.1.1-0.1.20090310git3a31d26.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/geoclue-0.11.1.1-0.1.20090310git3a31d26.fc9
Comment 8 Fedora Update System 2009-04-17 14:03:18 EDT
geoclue-0.11.1.1-0.1.20090310git3a31d26.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update geoclue'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3727
Comment 9 Fedora Update System 2009-04-17 14:04:45 EDT
geoclue-0.11.1.1-0.1.20090310git3a31d26.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update geoclue'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3735
Comment 10 Fedora Update System 2009-04-22 16:27:20 EDT
geoclue-0.11.1.1-0.1.20090310git3a31d26.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-04-24 15:49:33 EDT
geoclue-0.11.1.1-0.1.20090310git3a31d26.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.