Bug 466667 - cjkunifont install packages in inexistent directory
cjkunifont install packages in inexistent directory
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cjkunifonts (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-12 11:10 EDT by Nicolas Mailhot
Modified: 2008-12-06 23:20 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-06 23:20:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-10-12 11:10:26 EDT
cjkunifont 0_2_20080216_1-4_fc10 has been changed to install files in /etc/fonts/conf.avail, deviating from our official packaging guidelines
http://fedoraproject.org/wiki/Packaging/FontsSpecTemplate

As a result it may now install files in an unowned directory, with all the associated problems, since /etc/fonts/conf.avail is not referenced in our guidelines and not provided by filesystem like /etc/fonts/conf.d

Moreover /etc/fonts/conf.avail is hosting file templates which are not modifiable, and should be moved to /usr/share to respect the FHS. Any packager that will follow this unfortunate example will now make rpmlint complain. So upholding this pattern would require modifying rpmlint too.

This is all a big mess.

All those problems would have been identified had the deviation from guidelines been properly discussed on the fonts list beforehand. Please do not deviate from guidelines in the future without public discussion.

Since I'm a nice guy, I've posted a guidelines change request here
http://fedoraproject.org/wiki/PackagingDrafts/Fonts_spec_template_correction_(fontconfig)

Please participate in this guideline change discussion now and abide *strictly* by FPC's ultimate decision.
Comment 1 Jens Petersen 2008-10-12 22:53:24 EDT
(Ok, sorry this probably my fault since I suggested it: I thought conf.avail was in common use.)
Comment 2 Caius Chance 2008-10-13 01:54:58 EDT
Thanks Nicolas and Jens,

Reverted: http://koji.fedoraproject.org/koji/buildinfo?buildID=66127
Comment 3 Nicolas Mailhot 2008-10-13 02:19:23 EDT
(In reply to comment #1)
> (Ok, sorry this probably my fault since I suggested it: I thought conf.avail
> was in common use.)

It's not in Fedora for various reasons.
But let that not stop you from participating to the guideline change review
Comment 4 Jens Petersen 2008-10-28 20:54:32 EDT
cjkunifonts-0.2.20080216.1-8.fc10 still has conf.avail:

http://koji.fedoraproject.org/koji/buildinfo?buildID=66127 (build)
http://koji.fedoraproject.org/koji/rpminfo?rpmID=792449 (uming info)
http://koji.fedoraproject.org/koji/rpminfo?rpmID=792450 (ukai info)
Comment 6 Caius Chance 2008-10-28 21:56:12 EDT
Built on rawhide (dist-f11), but need to clone to f10, too.
Comment 7 Caius Chance 2008-10-28 22:01:24 EDT
Keep opened as f10 is not selectable in bz yet.
Comment 8 Bug Zapper 2008-11-25 22:48:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2008-12-01 00:41:47 EST
cjkunifonts-0.2.20080216.1-9.2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cjkunifonts-0.2.20080216.1-9.2.fc10
Comment 10 Caius Chance 2008-12-01 00:43:05 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=965107

This bug ticket will be closed when pushed to f10 update.
Comment 11 Fedora Update System 2008-12-02 20:11:36 EST
cjkunifonts-0.2.20080216.1-9.2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cjkunifonts'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10504
Comment 12 Fedora Update System 2008-12-06 23:20:49 EST
cjkunifonts-0.2.20080216.1-9.2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.