Bug 466671 - broken W: non-break-space warning
broken W: non-break-space warning
Status: CLOSED DUPLICATE of bug 455371
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-12 11:36 EDT by Nicolas Mailhot
Modified: 2008-10-12 13:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-12 13:36:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-10-12 11:36:50 EDT
rpmlint-0.84-3.fc10.noarch includes a stupid and broken non-break-space warning.

It's stupid because the distro official policy is that spec files are UTF-8 files and there's no reason to blacklist UTF-8 parts

It's broken because it triggers randomly on various UTF-8 strings, including strings that do not include non-break-space at all, so the packager can not even act on the stupid thing.

An exemple trigger spec is in bug #453017. The source seems to be korean text which has been included to follow our official guidelines on translating if possible.

So we have a warning that protects against something the guidelines do not forbid, triggers randomly on other stuff, including stuff which has been added to follow the actual packaging guidelines.

This warning does not deserve to survive.
Comment 1 Ville Skyttä 2008-10-12 13:36:51 EDT
Please calm down, this is just a bug in rpmlint which has been reported earlier, fixed upstream and will be in the next release.  I've verified that the rpmlint svn version does the right thing with the spec from bug 453017.

*** This bug has been marked as a duplicate of bug 455371 ***

Note You need to log in before you can comment on or make changes to this bug.