Bug 466680 - [RFE] Enable opengl transitions for Impress
[RFE] Enable opengl transitions for Impress
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-12 14:37 EDT by Jonathan Dieter
Modified: 2008-12-15 15:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 11:25:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 96946 None None None Never

  None (edit)
Description Jonathan Dieter 2008-10-12 14:37:46 EDT
A while back, a number of 3D transitions were created for OpenOffice.org Impress.  I'd love to see them included either in Fedora 9 or Fedora 10.  Unfortunately, I'm not sure where upstream is for them.
Comment 1 Caolan McNamara 2008-10-12 17:46:56 EDT
no-one knows what the right upstream for them really is, they are smeared across vanilla/ooo-build as part of a google summer of code. As with anything around 3d graphics, they'll work for some cards, be a hideous disaster for some cards.

My plan is to just get F-10 out the door, and pull this together after F-10 for F-11 as an optional packaged extension.
Comment 2 Jack Deslippe 2008-12-04 15:43:46 EST
I am also interested in seeing the ogltrans included.  Is it in rawhide yet?  Ubuntu packages them as a separate add on package.  That way they are not installed by default on computers without the required graphics card.
Comment 3 Caolan McNamara 2008-12-04 18:08:12 EST
I'm waiting on a response from some specific developers as to whether various ogltrans pieces are intended for upstream, in which case there's some work to be done to integrate it in which I'm willing to do. Or if they are intended to not be in upstream, in which case there's some different work to be done.
Comment 4 Caolan McNamara 2008-12-05 07:15:58 EST
Intended for upstream, so I'll help out there (http://www.openoffice.org/issues/show_bug.cgi?id=96946) to get that done and hopefully sort it out by 3.1 and we'll either have that in F-11 or backport it
Comment 5 Caolan McNamara 2008-12-10 09:16:24 EST
Merged Novell's patches into upstream, moved it around into sdext and tweaked it to make it an extension. 

Lets try the resulting patch out in rawhide, checked in.
Comment 6 Caolan McNamara 2008-12-15 11:25:08 EST
Available as openoffice.org-transogl-3.0.1-13.2.fc11
Comment 7 Jack Deslippe 2008-12-15 15:19:23 EST
actually, it is ogltrans not transogl
Comment 8 Jack Deslippe 2008-12-15 15:20:59 EST
Is it possible to backport this to F10 somehow?  I tried to install it from rawhide but it wanted to grab a lot of other packages from rawhide as well.

Note You need to log in before you can comment on or make changes to this bug.