Bug 466684 - intel xorg driver kills screen (black) and keyboard on asus p5q-em G45 X4500
intel xorg driver kills screen (black) and keyboard on asus p5q-em G45 X4500
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-12 15:43 EDT by Jesse Hutton
Modified: 2009-09-06 03:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 03:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from a failed startup (25.99 KB, text/plain)
2008-10-12 15:46 EDT, Jesse Hutton
no flags Details
lspci output info (1.66 KB, text/plain)
2008-10-12 15:48 EDT, Jesse Hutton
no flags Details
xorg.conf (762 bytes, text/plain)
2008-10-12 15:49 EDT, Jesse Hutton
no flags Details
dmesg output (37.22 KB, text/plain)
2008-10-12 15:52 EDT, Jesse Hutton
no flags Details

  None (edit)
Description Jesse Hutton 2008-10-12 15:43:45 EDT
Description of problem:

X won't start with the intel driver, and it even kills the screen and keyboard so that a reboot is necessary. I can ssh into the box and read the logs (see below and attached), but even trying to restart X with the vesa driver from ssh (by going down to runlevel 3, editing xorg.conf, and back to runlevel 5) fails to rescue the system, and Ctrl-Alt F[1-7] does nothing at this point. 


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.4.2-9.fc10.x86_64 (from rawhide as of 10/12/08, although it hasn't worked in rawhide since I installed it here around a month ago)

How reproducible: 100%


Steps to Reproduce:
1. Set driver to 'intel' in xorg.conf
2. reboot or restart X
3.
  
Actual results:

Black screen and apparently dead keyboard. Switching virtual terminals doesn't work, and my attempts to reboot the system "blind" from the session failed (works over ssh though).

Expected results:

Normal X session using intel driver.

Additional info:

Tailing /var/log/messages shows the following when trying to start X:

 kernel: [drm] Initialized drm 1.1.0 20060810
 kernel: pci 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
 kernel: [drm:i915_driver_load] *ERROR* failed to enable MSI
 kernel: [drm] Initialized i915 1.6.0 20080730 on minor 0
 kernel: mtrr: type mismatch for d0000000,10000000 old: write-back new: write-combining

Keyboard is a Logitech Illuminated keyboard (new model and doesn't have specific layout config yet)
Comment 1 Jesse Hutton 2008-10-12 15:46:44 EDT
Created attachment 320151 [details]
Xorg.0.log from a failed startup
Comment 2 Jesse Hutton 2008-10-12 15:48:07 EDT
Created attachment 320152 [details]
lspci output info
Comment 3 Jesse Hutton 2008-10-12 15:49:22 EDT
Created attachment 320153 [details]
xorg.conf
Comment 4 Jesse Hutton 2008-10-12 15:52:22 EDT
Created attachment 320154 [details]
dmesg output
Comment 5 Jesse Hutton 2008-10-12 15:55:13 EDT
I've also tried with and without loading dri by commenting/uncommenting in xorg.conf, and the results have been exactly the same.
Comment 6 Mathieu B. 2008-11-05 15:52:05 EST
Same problem on my Laptop Dell E6400 with Intel X4500HD.

-> I'm using the new Fedora Preview i386

Exactly the same problem like Mandriva 2009: http://artipc10.vub.ac.be/serendipity/archives/71-Mandriva-Linux-2009.0-on-a-Dell-Latitude-E6400.html
Comment 7 Bug Zapper 2008-11-25 22:48:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Vedran Miletić 2009-09-06 03:46:56 EDT
Reporter, please try Fedora 11 or Fedora 12 Snap1. Support for this card was added since this bug has been reported.

Closing per bug 471669 which reports this card as working (not fully, but that's another thing).

Note You need to log in before you can comment on or make changes to this bug.