Bug 466698 - Incomplete suspend to disk causes un-recoverable error [NEEDINFO]
Incomplete suspend to disk causes un-recoverable error
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-10-12 19:17 EDT by Mohamed Yehiya
Modified: 2015-03-04 20:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 10:33:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pknirsch: needinfo? (mdyehiya)

Attachments (Terms of Use)

  None (edit)
Description Mohamed Yehiya 2008-10-12 19:17:24 EDT
Description of problem:
                      Due to some odd reason the system haven't got into the suspend to disk. With the above reason during the next startup system showed up only prompt "GRUB"

Version-Release number of selected component (if applicable):

Fedora 9 on 

Linux yehiya-pc.localdomain #1 SMP Sat Sep 20 03:45:00 EDT 2008 i686 i686 i386 GNU/Linux

How reproducible:
                Steps are explained below

Steps to Reproduce:
1.System about reaching empty of battery life (7 mins left, alert in my case)
2.Closed some applications which are not required for next boot.
3.Clicked on the option "Suspend to Disk"
4.System response was quite normal, HDD leds were glowing showing the suspend is process. 
5. But this time system quickly suspended to disk (to my surprise)
6. On restart of next time system will show only "GRUB" and not able to proceed.


7. Tried Fedora 9 DVD to update only "boot loader" options alone, but in vain
8. Tried option "Upgrade", system prompted "Your swap (/dev/sdb3) is full having details of previous suspended data, do you wish to format "
9. Choose the format option and continued update to make system up.
10. Now when ever the system startup, getting some errors with meaning "unable to recover, unmounting old /dev/  .. so on "
Actual results:

Expected results: 

Additional info:
Comment 1 Phil Knirsch 2009-05-07 08:11:57 EDT
Could you try to reformat your swap partition after the system booted?

Also, the /var/log/messages with the boot messages would be interesting.

Other than that is your swap partition large enough to save your whole memory?

Thanks & regards, Phil
Comment 2 Bug Zapper 2009-06-09 22:56:58 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 3 Bug Zapper 2009-07-14 10:33:46 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.