Bug 466740 - [man pages] chkconfig(8) has run level 7 which does not exist
[man pages] chkconfig(8) has run level 7 which does not exist
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: chkconfig (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Bill Nottingham
BaseOS QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 07:15 EDT by Alexander Todorov
Modified: 2014-03-16 23:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 07:15:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-10-13 07:15:08 EDT
+++ This bug was initially created as a clone of Bug #466739 +++

Description of problem:
The manual page chkconfig(8) shows:

<quote>
OPTIONS
       --level levels
              Specifies  the  run levels an operation should pertain to. It is given as a string of numbers from 0 to 7. For example, --level 35 specifies
              runlevels 3 and 5.
</quote>

There's no run level 7, and indeed chkconfig doesn't accept 7 as a valid level parameter. The valid values are from 0 to 6 inclusive.


Version-Release number of selected component (if applicable):
chkconfig-1.3.30.1-2

How reproducible:
Always

Steps to Reproduce:
1. man chkconfig
2. search for "7"

  
Actual results:
Incorrect run level 7 specified

Expected results:
Run level 0-6 are specified

Additional info:
It's the chkconfig man page from RHEL5.2 but I believe it's present in 5.3 as well because it's not fixed in F9 too.
Comment 1 RHEL Product and Program Management 2008-10-13 08:03:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 Bill Nottingham 2008-12-04 14:56:12 EST
I don't see that it's worth a specific fix for this. If we have actual bug fixes that require an update, sure, we can put it in.
Comment 4 RHEL Product and Program Management 2008-12-04 15:04:42 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 8 Bill Nottingham 2009-11-02 14:27:31 EST
Building as 1.3.30.2-1.el5.
Comment 12 errata-xmlrpc 2009-12-02 07:15:16 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1628.html

Note You need to log in before you can comment on or make changes to this bug.