Bug 466748 - [or_IN] Needed ZWJ & ZWNJ for Oriya Inscript keymap
[or_IN] Needed ZWJ & ZWNJ for Oriya Inscript keymap
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: m17n-contrib (Show other bugs)
rawhide
All All
medium Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 08:35 EDT by Manoj Kumar Giri
Modified: 2015-04-19 20:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 09:50:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manoj Kumar Giri 2008-10-13 08:35:52 EDT
Description of problem:
# Due to the absence of ZWJ & ZWNJ we can't make appropriate conjunction.

Version-Release number of selected component (if applicable):


How reproducible:Always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rahul Bhalerao 2008-10-15 06:30:40 EDT
Manoj, Can you please mention exactly which keyboard map do you want these keys to be mapped and where? As of now, for INSCRIPT keymap, Shift-9 and Shift-0 look like most appropriate and empty keys for ZWJ and ZWNJ respectively.Can you please confirm if this would resolve your issue?
Comment 2 Manoj Kumar Giri 2008-10-15 07:17:36 EDT
Hi Rahul,
      For INSCRIPT keymap, empty keys Shift-9 and Shift-0
are suitable for ZWJ and ZWNJ respectively. We can go ahead with this.

Thanks & Regards
Manoj
Comment 3 Manoj Kumar Giri 2008-11-04 08:10:48 EST
Hi Rahul,
         Any updates on this issue.

Thanks & Regards
Manoj
Comment 4 Fedora Update System 2008-11-05 05:40:18 EST
m17n-contrib-1.1.8-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/m17n-contrib-1.1.8-2.fc10
Comment 5 Fedora Update System 2008-11-08 01:02:00 EST
ibus-m17n-0.1.1.20081013-3.fc9,m17n-contrib-1.1.8-2.fc9,m17n-db-1.5.3-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/ibus-m17n-0.1.1.20081013-3.fc9,m17n-contrib-1.1.8-2.fc9,m17n-db-1.5.3-1.fc9
Comment 6 Subhransu Behera 2008-11-11 08:05:47 EST
Hi, as per community discussions, we think it will be good to have ZWJ and ZWNJ in position 
z/Z respectively in Inscript keymap layout.

The reason we want to go for it is because these keys are most frequently used in English 
key-map and currently have no characters in them. It will be quite simpler for the end user 
to use them in practice. 

Beside that, these keys are used in combination with halanth (U+0B4D), and the current 
position of the same is 'd'. So it makes sense to have the JWZ/JWNJ in the position of z/Z.

Can this issue be addressed and we can submit a patch for the next version? Suggestions?
Comment 7 Parag AN(पराग) 2008-11-11 08:20:20 EST
Thanks Subhranshu for your comment.
I would like to see comment from mgiri on issues asked by you.
Comment 8 Fedora Update System 2008-11-11 22:00:50 EST
ibus-m17n-0.1.1.20081013-3.fc9, m17n-contrib-1.1.8-2.fc9, m17n-db-1.5.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n m17n-contrib m17n-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9603
Comment 9 Parag Nemade 2008-11-13 02:38:03 EST
I think in order to make uniform access of zwj/zwnj in inscript keymaps as discussed in Indic Mashup meeting, we will go ahead with Shift+9 and Shift+0 for ZWJ, ZWNJ respectively.
Comment 10 Fedora Update System 2008-11-19 09:49:57 EST
ibus-m17n-0.1.1.20081013-3.fc9, m17n-contrib-1.1.8-2.fc9, m17n-db-1.5.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-11-22 11:51:52 EST
m17n-contrib-1.1.8-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.