Bug 466773 - Dialogue offers me to log out from GDM
Dialogue offers me to log out from GDM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-10-13 11:17 EDT by Bastien Nocera
Modified: 2008-10-24 19:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 19:07:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2008-10-13 11:17:40 EDT
1. Boot laptop
2. When at gdm, press "Power button"
3. Get dialogue telling me:
"Log out of this system now?
You are currently logged in as "gdm"
You will be automatically logged out in XX seconds".

[Switch user] [Log out] [Cancel]
"
Comment 1 Matthias Clasen 2008-10-14 00:04:18 EDT
Another interesting point to notice is that if I do this while another session is running, the dialog pops up in all sessions.
Comment 2 Matthias Clasen 2008-10-14 00:06:34 EDT
The dialog comes from gnome-session
Comment 3 Matthias Clasen 2008-10-14 00:15:46 EDT
gnome-settings-daemon handles the power button, and currently calls

gnome-session-save --kill

I wonder if thats a leftover from when we had a single dialog that also had shutdown in it. Nowadays we have a separate shutdown dialog, and we should
probably call

gnome-session-save --shutdown-dialog 

instead ?
Comment 4 Matthias Clasen 2008-10-15 17:15:54 EDT
I've fixed gnome-settings-daemon to call gnome-session-save --shutdown-dialog,
but it turns out that currently, gnome-power-manager handles the key and causes the logout dialog to be displayed. I hear that the key handling is going to move to X very soon, though.
Comment 5 Matthias Clasen 2008-10-24 19:07:04 EDT
This was fixed in gnome-power-manager to bring up the shutdown dialog.

Note You need to log in before you can comment on or make changes to this bug.