Bug 466775 - DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property Hostname
DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property Hostname
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
anaconda_trace_hash:dc8b00f2fbdf8f11c...
:
: 466546 (view as bug list)
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-10-13 11:25 EDT by James Laska
Modified: 2013-09-02 02:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 13:28:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (87.19 KB, text/plain)
2008-10-13 11:25 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (87.53 KB, text/plain)
2008-10-13 12:18 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (65.47 KB, text/plain)
2008-10-14 12:26 EDT, Tomasz Torcz
no flags Details
Attached traceback automatically from anaconda. (96.17 KB, text/plain)
2008-10-15 13:28 EDT, Shashin Shinde
no flags Details
Attached traceback automatically from anaconda. (49.37 KB, text/plain)
2008-10-15 13:50 EDT, Will Woods
no flags Details
Attached traceback automatically from anaconda. (65.20 KB, text/plain)
2008-10-16 08:11 EDT, Marcela Mašláňová
no flags Details

  None (edit)
Description James Laska 2008-10-13 11:25:49 EDT
This bug was filed automatically by anaconda.
Comment 1 James Laska 2008-10-13 11:25:57 EDT
Created attachment 320193 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2008-10-13 12:18:41 EDT
Created attachment 320197 [details]
Attached traceback automatically from anaconda.
Comment 3 James Laska 2008-10-14 07:42:01 EDT
Snippet of traceback from attachment#320193 [details]

anaconda 11.4.1.48 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/anaconda/network.py", line 96, in getDefaultHostname
    hostname = ip4_config_props.Get(isys.NM_MANAGER_IFACE, "Hostname")
  File "/usr/lib/anaconda/iw/network_gui.py", line 38, in getScreen
    self.hostname = network.getDefaultHostname(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1436, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1353, in nextClicked
    self.setScreen ()
DBusException: org.freedesktop.DBus.Error.InvalidArgs: No such property Hostname
Comment 4 Tomasz Torcz 2008-10-14 12:26:46 EDT
Created attachment 320322 [details]
Attached traceback automatically from anaconda.
Comment 5 Chris Lumens 2008-10-14 14:20:53 EDT
Hostname is no longer a property NM provides, so we just need to be using socket.gethostname every time.  This should be fixed in the next build of anaconda.
Comment 6 David Cantrell 2008-10-14 23:44:33 EDT
I've updated Chris' patch a bit so we get the IP address of the interface from NetworkManager via D-Bus and do a socket.gethostbyaddr() before falling back on socket.gethostname() and eventually falling back on localhost.localdomain.
Comment 7 David Cantrell 2008-10-14 23:46:19 EDT
*** Bug 466546 has been marked as a duplicate of this bug. ***
Comment 8 Shashin Shinde 2008-10-15 13:28:19 EDT
Created attachment 320463 [details]
Attached traceback automatically from anaconda.
Comment 9 Will Woods 2008-10-15 13:50:52 EDT
Created attachment 320465 [details]
Attached traceback automatically from anaconda.
Comment 10 Marcela Mašláňová 2008-10-16 08:11:42 EDT
Created attachment 320545 [details]
Attached traceback automatically from anaconda.
Comment 11 James Laska 2008-10-16 13:27:20 EDT
Fixed in Fedora development i386 (20081016) which contains anaconda-11.4.1.49-1.i386

Note You need to log in before you can comment on or make changes to this bug.