Bug 466779 - atk seems to have package conflicts with the i386 variant (see bugzilla entry 466633)
atk seems to have package conflicts with the i386 variant (see bugzilla entry...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: atk (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 11:41 EDT by Arnold Sutter
Modified: 2008-10-13 17:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 11:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arnold Sutter 2008-10-13 11:41:32 EDT
Description of problem:
When trying to install Adobe Reader from the Adobe YUM Repository, it requests many i386 variants of installed packages. Now it seems that atk cannot have both package variants (x86_64 and i386) installed, at least YUM complains because of file conflicts saying "atk10.mo" is already installed (See bugzilla entry 466633 for a detailed typescript about this).

Version-Release number of selected component (if applicable):
atk-1.24.0-1.fc10.i386

How reproducible:
yum -y install AdobeReader_enu (with a registered Adobe YUM repo on an x86_64 system).

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Many yum errors like this one:

Transaction Check Error:
  file /usr/share/locale/af/LC_MESSAGES/atk10.mo from install of atk-1.24.0-1.fc10.i386 conflicts with file from package atk-1.23.5-1.fc10.x86_64

Expected results:
The i386 variant of atk should install seamless.

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=466633
Comment 1 Matthias Clasen 2008-10-13 11:52:13 EDT
[mclasen@localhost devel]$ ~/Desktop/multilib-cmp.py atk-1.24.0-1.fc10.i386.rpm atk-1.24.0-1.fc10.x86_64.rpm 
No conflicts


You have different versions of atk installed for i386 and x86_64. 
No wonder they conflict.
Comment 2 Arnold Sutter 2008-10-13 17:12:01 EDT
Hello Mat, 

yes, just realized that I had 2 versions of atk installed, after removing the old one, I could install AcrobatReader_enu without issues. 

Thanks much & best Regards, 

Arnold

Note You need to log in before you can comment on or make changes to this bug.