Bug 466785 - option to upgrade is missing from install media
option to upgrade is missing from install media
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 12:07 EDT by John Reiser
Modified: 2013-01-09 23:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-23 16:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/anaconda.log when no upgrade offered (7.89 KB, text/plain)
2008-10-13 14:07 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2008-10-13 12:07:47 EDT
Description of problem: The boot screen "Welcome to Fedora-Beta 10!" contains the default option "Install or upgrade an existing system" but the flow contains no check for an existing installed system, and no dialog to upgrade such an existing system.


Version-Release number of selected component (if applicable):
anaconda-11.4.1.48-1.i386


How reproducible: always


Steps to Reproduce:
1. boot DVD or CD, choose default "Install or upgrade an existing system"
2. proceed with dialogs
3.
  
Actual results: No dialog to update an existing system, despite the box having 6 partitions that each had an existing Fedora or RHEL installed system.  The screens were:
Welcome to Fedora-Beta 10!
Disc Found (option to test media)
Media Detected
graphical splash screen
choose language
choose keyboard
confirm pre-release
    <<< check for upgrade probably belongs here >>>
specify hostname
choose timezone
choose root password
choose harddrive for new install
...

Expected results: Dialog with option to upgrade existing system.


Additional info: DVD and CD composed by pungi from today's rawhide (Mon.Oct.13.)
Comment 1 Chris Lumens 2008-10-13 13:35:46 EDT
We probably are scanning for systems that could potentially be upgraded, but not finding any that we like and therefore skipping showing the screen.  Can you attach /tmp/anaconda.log to this bug report?  What's on the installed systems, and does adding the upgradeany option make the screen appear?
Comment 2 John Reiser 2008-10-13 14:07:50 EDT
Created attachment 320214 [details]
/tmp/anaconda.log when no upgrade offered

The anaconda log for default boot "Install or upgrade ..." with no additional parameters on kernel command line.
Comment 3 John Reiser 2008-10-13 14:14:46 EDT
Adding " upgradeany" to the kernel boot command line does insert an Install/Upgrade dialog after the dialog for "choose keyboard", and the drop-down list box has 17 choices (all root partitions with a Linux system installed.)

One harddrive has these systems:
f9-32
f9-64
f10-32  "alpha"
ub804-32
f10-64  "beta"
f10-32  "beta"

The other harddrive has:
ub704-32
SuSE10.2-32
fc6-32
fc6-64
f7-32
f7-64
Cent50-32
Cent50-64
debian-64
f8-64
f8-32
Comment 4 Chris Lumens 2008-10-14 13:34:24 EDT
The fact that upgradeany works, combined with the mount messages in your log file indicate we are correctly scanning the partitions.  We determine if an install is upgradable by checking that the product name as provided in /etc/redhat-release on the installed system matches the product name in /.buildstamp in the anaconda image.  So, "Fedora" can upgrade "Fedora".  Similarly, "Fedora" can upgrade "Fedora Core" because we allow that too.
Comment 5 John Reiser 2008-10-14 14:19:35 EDT
The DVD images/install.img contains a /.buildstamp with "Fedora-Beta";  /etc/redhat-release from the f10-32 system has "Fedora release 9.92 (Rawhide)".  Do these match?  Or does the name "Fedora-Beta" on the DVD or CD mean that only a system with "Fedora-Beta" in /etc/redhat-release can be upgraded?  If I re-ran pungi using "name Fedora" on the command line instead of "name Fedora-Beta", then would I be able to test upgrad install?
Comment 6 Chris Lumens 2008-10-14 14:39:19 EDT
Right, "Fedora release 9.92" does not start with "Fedora-Beta" and isn't an upgrade path that we explicitly allow in our checks so that's the problem.  I believe that using a name of "Fedora" when running pungi would correct the problem.

If we're going to continue using Fedora-Beta in future releases AND we plan on having an upgrade to the beta being a supported path, we need to correct this in anaconda.  Otherwise we need to make sure we're using the right name when we compose.
Comment 7 Chris Lumens 2008-10-23 10:11:40 EDT
This string in .buildstamp is just the value of --product that's passed into buildinstall and therefore into mk-treeinfo and mk-images.  Reassigning to pungi for now since that's what calls buildinstall, but perhaps this was just a one-time problem?
Comment 8 John Reiser 2008-10-23 14:52:36 EDT
Today it works for me if I compose via pungi with "--name Fedora" [note missing "-Beta"]: I am offered a chance to upgrade Fedora 9, Fedora-Beta 9.92, Red Hat 4, Red Hat 5.  This is using:
  pungi-2.0.6-1.fc10.norach
  anaconda-11.4.1.50-1.x86_64

If I compose via pungi with "--name Fedora-Beta" (which is the suggested default) then I am not offered a chance to upgrade anything, not even Fedora-Beta 9.92.
Comment 9 Jesse Keating 2008-10-23 15:18:03 EDT
Suggested default?  Where is this suggested?
Comment 10 John Reiser 2008-10-23 16:00:23 EDT
[In reply to Comment #9] During the Fedora 10 beta cycle, one of the .rpms for pungi had a manual page with the EXAMPLE "pungi -c /usr/share/pungi/rawhide-fedora.ks --destdir=/data/Fedora --name Fedora-Beta --ver 10".  I copied that into my command shell command line.
Comment 11 Jesse Keating 2008-10-23 16:24:11 EDT
Er, the man page doesn't have that, and never had that.  The Example line remains untouched from it's introduction into the source repository.  I'm going to close this bug.

Note You need to log in before you can comment on or make changes to this bug.