Bug 466818 - HP ProCurve switches, APC master switches drop connection after login
HP ProCurve switches, APC master switches drop connection after login
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 16:33 EDT by Jan "Yenya" Kasprzak
Modified: 2008-11-06 21:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 21:51:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ssh -v with 5.0p1 and 5.1p1 to the APC master switch. (3.63 KB, text/plain)
2008-10-13 16:41 EDT, Jan "Yenya" Kasprzak
no flags Details
ssh -vvv to the APC master switch (5.0p1) (9.68 KB, application/octet-stream)
2008-10-14 12:34 EDT, Jan "Yenya" Kasprzak
no flags Details
ssh -vvv to the APC master switch (5.1p1) (7.78 KB, application/octet-stream)
2008-10-14 12:37 EDT, Jan "Yenya" Kasprzak
no flags Details

  None (edit)
Description Jan "Yenya" Kasprzak 2008-10-13 16:33:20 EDT
Description of problem:
After a recent upgrade I am no longer able to log in to the embedded devices like HP ProCurve ethernet switches or APC master switches - the remote device just closes the connection after receiving the password.

Version-Release number of selected component (if applicable):
openssh-server-5.1p1-2.fc9.i386
openssh-clients-5.1p1-2.fc9.i386
openssh-askpass-5.1p1-2.fc9.i386
openssh-5.1p1-2.fc9.i386

How reproducible:
100 %

Steps to Reproduce:
1. install the above version of openssh
2. try to log in to the remote device using password
  
Actual results:
connection is closed by the remote side. APC master switches do not
say anything, with HP ProCurve ssh says the following:

Received disconnect from XXX: 2: protocol error: rcvd type 80

Expected results:
Command-line prompt on HP ProCurve (tested 2650, 2848, 4300), menu screen on
APC (tested version 7920).

Additional info:
Downgrading to 5.0p1-1.fc9 fixes the problem. The problem happens at least on i386 and x86_64.

I will attach the two ssh -v sessions (one with 5.0p1-1.fc9, the other one with 5.1p1-2.fc9).
Comment 1 Jan "Yenya" Kasprzak 2008-10-13 16:41:04 EDT
Created attachment 320228 [details]
ssh -v with 5.0p1 and 5.1p1 to the APC master switch.
Comment 2 Tomas Mraz 2008-10-14 07:17:09 EDT
Do you see anything suspicious in ssh -vvv session with the 5.1p1?
Comment 3 Jan "Yenya" Kasprzak 2008-10-14 12:34:06 EDT
Created attachment 320323 [details]
ssh -vvv to the APC master switch (5.0p1)
Comment 4 Jan "Yenya" Kasprzak 2008-10-14 12:37:56 EDT
Created attachment 320325 [details]
ssh -vvv to the APC master switch (5.1p1)

OK, here you are. Running diff -u on the above two files did not show anything I can make sense of :-)

[Meta: is it just me, or is Bugzilla these days _awfully_ slow? Just opening the bug page took about half a minute here, the same for adding attachments and every other page]
Comment 5 Fedora Update System 2008-10-17 05:31:39 EDT
openssh-5.1p1-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/openssh-5.1p1-3.fc9
Comment 6 Jan "Yenya" Kasprzak 2008-10-17 05:35:51 EDT
Works for me (tested x86_64 arch only, against both HP and APC boxes). Thanks for solving the problem this fast!

[Meta from the comment #4 stil holds, bugzilla is still very slow here]
Comment 7 Tomas Mraz 2008-10-17 06:43:57 EDT
Upstream solved it just today, not me :)
Comment 8 Fedora Update System 2008-11-06 21:51:38 EST
openssh-5.1p1-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.