Bug 466821 - evolution misrepresents contents of imap mailboxes
evolution misrepresents contents of imap mailboxes
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 16:46 EDT by Thomas J. Baker
Modified: 2008-11-05 07:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 07:57:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 554468 None None None Never

  None (edit)
Description Thomas J. Baker 2008-10-13 16:46:00 EDT
I just wanted to make sure this was in the Fedora bugzilla.  evolution-2.24.0-3.fc10 can misrepresent the contents of imap mailboxes. Examples include these:

show mail that no longer exists on the server. When you try to read such a message, it gives an error about not being able to fetch the mail. This can happen when you read mail from multiple machines and evolution fails to update it's view of a folder correctly.

evolution shows a folder as being empty even though I drag and drop mail messages from one folder into it. No amount of quitting and restarting can get evolution to see the mail. Older versions of evo see the mailbox correctly.

My initial bug submitted to gnome is here: 
http://bugzilla.gnome.org/show_bug.cgi?id=554468 

This master bug may be relevant too:
http://bugzilla.gnome.org/show_bug.cgi?id=543389

I'm worried as I haven't seen any updates to evolution and I don't dare to install the beta on my workstation because mail has got to work. (I have it installed on a test system and my laptop.)
Comment 1 Milan Crha 2008-11-05 07:57:14 EST
Hi Thomas, thanks for the report. I see you are discussing your issue with the upstream developer in the upstream bug, thus I will close this one appropriately, also because it'll be better to share this issue with them (I know, the update helped with the issues, but it's still not that perfect).

Note You need to log in before you can comment on or make changes to this bug.