Bug 466823 - Monitoring packages to rebuild
Monitoring packages to rebuild
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: space03
  Show dependency treegraph
 
Reported: 2008-10-13 17:10 EDT by Miroslav Suchý
Modified: 2009-09-17 03:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:02:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-10-13 17:10:17 EDT
This packages need to be rebuild for spacewalk 0.3 to have functional monitoring:

spacewalk-proxy-monitoring
ConfigPusher-general
eventReceivers
NOCpulsePlugins
NPalert
nocpulse-common
perl-NOCpulse-CLAC
perl-NOCpulse-Debug
perl-NOCpulse-Gritch
perl-NOCpulse-Object
perl-NOCpulse-OracleDB
perl-NOCpulse-PersistentConnection
perl-NOCpulse-Probe
perl-NOCpulse-ProcessPool
perl-NOCpulse-Scheduler
perl-NOCpulse-SetID
perl-NOCpulse-Utils
ssl_bridge
scdb
SNMPAlerts
SatConfig-bootstrap
SatConfig-bootstrap-server
SatConfig-cluster
SatConfig-dbsynch
SatConfig-general
SatConfig-generator
SatConfig-installer
SatConfig-spread
SputLite-client
SputLite-server
status_log_acceptor
tsdb
ProgAGoGo
MessageQueue
nocpulse-db-perl
Comment 1 Clifford Perry 2008-10-21 13:32:18 EDT
Milan for EL4 and EL5 has been working on this task along with Mirek. 

Please move to MODIFIED once you feel confident that this is done. 

Cliff
Comment 2 Miroslav Suchý 2008-10-22 04:38:19 EDT
It is rebuilt.
Comment 3 Milan Zázrivec 2008-10-22 08:24:42 EDT
All of the packages from comment #0 were rebuilt in our satellite-[45]E-5.3-build
tags only. Not in spacewalk-[45]E-0.3 tags.

I'm moving this bugzilla back to ASSIGNED.
Comment 4 Milan Zázrivec 2008-10-22 09:29:51 EDT
spacewalk-5E-0.3-build lacks many of the perl-* packages we need
in the buildroot for building other monitoring packages.

Most of them are not even allowed for the list of spacewalk-5E-0.3(-build)

Fixing this problem is a several days activity (3-4 days at least).
Comment 5 Milan Zázrivec 2008-10-22 17:51:10 EDT
So far I rebuilt everything from monitoring except from
perl-DBD-Oracle and perl-NOCpulse-OracleDB.
Comment 6 Milan Zázrivec 2008-10-28 09:39:00 EDT
So based on the latest communication from satellite-devel-list@redhat.com
it looks like I won't have to rebuild these oracle - dependent packages
for Spacewalk 0.3.

I've been told that we currently have a working perl-DBD-Oracle + cx_Oracle
so I think my work here is done. I'm moving the bugzilla to modified.
Comment 7 Miroslav Suchý 2009-09-17 03:02:03 EDT
Spacewalk has been released for some time.

Note You need to log in before you can comment on or make changes to this bug.