Bug 466831 - pkgSkipList is not being honored for automatic updates from RHN
pkgSkipList is not being honored for automatic updates from RHN
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Milan Zázrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 18:22 EDT by Tim Mooney
Modified: 2010-10-26 07:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 16:41:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Mooney 2008-10-13 18:22:37 EDT
Description of problem:

On a RHEL 4.7 box, with up2date-4.7.1-17.el4, the pkgSkipList is not being honored when automatic updates are applied via RHN.  The pkgSkipList from /etc/sysconfig/rhn/up2date has:

pkgSkipList=kernel*;java*;java-1.5.0-ibm;java-1.5.0-ibm-devel;

Yet every time an updated release of java-1.5.0-ibm is available, it's automatically applied via our RHN subscription.  This breaks an application
that we have running on the system, and causes unplanned down-time.

We have our own Satellite server, if that matters.  We're running Satellite 4.2.3.

The first time this happened, we thought that perhaps it was because we had
not restarted rhnsd when the pkgSkipList was modified (via editing the file
directly).  However, we've restarted rhnsd several times since then, and the
last two java-1.5.0-ibm updates have still been applied.

Version-Release number of selected component (if applicable):


How reproducible:

It has happened the last three times Red Hat has released an updated version of
java-1.5.0-ibm and java-1.5.0-ibm-devel, so it can be reproduced.

Steps to Reproduce:
1. Red Hat releases an updated java-1.5.0-ibm release (like 1.5.0.8)
2. just wait, it will be installed despite the pkgSkipList
3.
  
Actual results:

java-1.5.0-ibm and java-1.5.0-ibm-devel still get automatically updated,
despite the contents of the pkgSkipList

Expected results:

They should be skipped.


Additional info:
Comment 3 Milan Zázrivec 2010-10-05 04:16:25 EDT
I've checked and tested the behavior of up2date in both RHEL-4.7 and
RHEL-4.8 and the pkgSkipList feature works correctly: the packages listed
are being skipped during automatic errata update scheduler by Satellite.

The only way you can achieve the behavior described in the initial comment
(i.e. pkgSkipList directive is being ignored during automatic errata update)
is when you set forceInstall directive in /etc/sysconfig/rhn/up2date to Yes
(it's configurable via up2date-config utility for example).

From /etc/sysconfig/rhn/up2date:
...
forceInstall[comment]=Force package installation, ignoring package, file and 
config file skip list
forceInstall=1
...

If you believe this is not the case, please raise your concern. Otherwise
I'm inclined to close this bug report with resolution 'worksforme'.

Thank you
Comment 4 Tim Mooney 2010-10-08 12:03:52 EDT
We also believe that this issue was fixed some time several months ago, as we noticed the problem seemed to stop at some point, so I'm fine with this issue being closed.

I can, however, guarantee that it was not working when I reported this bug.  forceInstall is set to 0 and has never been modified.
Comment 5 Milan Zázrivec 2010-10-08 16:41:40 EDT
Thank you for this feedback.

I have no reason to question the validity of the opening report, though
I'm currently unable to reproduce the problem.

If the problem reappears, please feel free to reopen this bug.

Closing with 'worskforme' for now.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.