Bug 466851 - HDA Intel/STAC92xx Analog, Default mixer initialization incorrect, volume very low
HDA Intel/STAC92xx Analog, Default mixer initialization incorrect, volume ver...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 02:37 EDT by Răzvan Sandu
Modified: 2009-12-18 01:34 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:34:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pavucontrol - tab 1 (65.37 KB, image/png)
2008-11-02 06:02 EST, Răzvan Sandu
no flags Details
pavucontrol - tab2 (61.22 KB, image/png)
2008-11-02 06:03 EST, Răzvan Sandu
no flags Details
pavucontrol - tab 3 (67.14 KB, image/png)
2008-11-02 06:04 EST, Răzvan Sandu
no flags Details
pavucontrol - tab 4 (69.05 KB, image/png)
2008-11-02 06:04 EST, Răzvan Sandu
no flags Details
An audio CD is just inserted... (78.69 KB, image/png)
2008-11-02 06:05 EST, Răzvan Sandu
no flags Details
Rythmbox doesn't play (153.97 KB, image/png)
2008-11-02 06:08 EST, Răzvan Sandu
no flags Details
VLC plays at very low volume (67.46 KB, image/png)
2008-11-02 06:11 EST, Răzvan Sandu
no flags Details
Totem's option to play CDs is deactivated (91.46 KB, image/png)
2008-11-02 06:13 EST, Răzvan Sandu
no flags Details
Sound Juicer says invalid stream (112.77 KB, image/png)
2008-11-02 06:19 EST, Răzvan Sandu
no flags Details

  None (edit)
Description Răzvan Sandu 2008-10-14 02:37:23 EDT
Description of problem:

On a system (which I've upgraded from Fedora 9 to latest rawhide), totem refuses to play any kind of file (despite the fact I've erased and reinstalled it completely via yum).

When double-clicking a media file, the error message is: "An error has occured: Failed to connect stream: Invalid argument".

I've tried to open:
- ogg files
- oga files 
- mp3 files
- mpg files

The corresponding files play with no problem using other players (mainly vlc).

I've discovered this after noting that SoundJuicer ripper now produces .oga files instead of .ogg and I've tried to play an .oga file.


Version-Release number of selected component (if applicable):
totem-2.24.2-2.fc10.x86_64
totem-xine-2.24.2-2.fc10.x86_64
totem-gstreamer-2.24.2-2.fc10.x86_64
totem-mozplugin-2.24.2-2.fc10.x86_64


How reproducible:
Always (on my system).

Steps to Reproduce:
1. Install the above totem packages
2. Double-click a multimedia file (free or non-free).

  
Actual results:
Totem doesn't play multimedia files.

Expected results:
Free multimedia files should play out of the box. Non-free multimedia files should play if the corresponding non-free codecs are installed (livna-supplied packages, via yum).

Additional info:
I've only enabled the official rawhide and livna-development yum repositories - in order to keep the soon-to-be Fedora 10 updated online, without package conflicts.
Comment 1 Bastien Nocera 2008-10-14 05:31:49 EDT
Launch totem from the command-line, you'll see that the error comes from pulseaudio itself.
Comment 2 Lennart Poettering 2008-10-19 16:22:31 EDT
Sounds like no audio device could be configured.

Which driver do you use?

Does "pavucontrol" show any output devices?
Comment 3 Răzvan Sandu 2008-10-19 22:44:09 EDT
Hello,

In the mean time, it works - after the latest online updates.

The device is HDA Intel - STAC92xx Analog (on a Dell Inspiron 1520 laptop):
http://www.smolts.org/client/show/pub_9d69eb22-c7a0-44ea-9e54-a49aa186b94c

Regards,
Răzvan
Comment 4 Matthias Clasen 2008-10-20 01:02:04 EDT
Thanks forthe update. Closing this bug then.
Comment 5 Răzvan Sandu 2008-10-24 16:13:24 EDT
Sorry, I was too optimistic about that - reopening bug.

I get the same error in SOME applications - for example, I cannot play CDs in rhytmbox or in sound juicer, while it works OK in gnome-mplayer.



Regards,
Razvan
Comment 6 Lennart Poettering 2008-10-24 16:22:36 EDT
Still sounds something is blocking your audio device when PA tries to open it. Does "pavucontrol" show any audio device for you?
Comment 7 Răzvan Sandu 2008-10-31 15:28:49 EDT
Hello,

Yes - as I said, it shows HDA Intel - STAC92xx Analog. I'm running on a Dell Inspiron 1520 laptop.

The audio device used to work with no problem since Fedora 8 - no special drivers required, just the software from the Fedora official DVD.

Thanks,
Răzvan
Comment 8 Lennart Poettering 2008-11-01 15:29:11 EDT
Can you please open pavucontrol, make sure the device exists and the try to reproduce the issue in Totem? 

I am pretty sure that some other app is simply blocking acecss to the audio device which will then result in the error message you encountered because PA has not audio device to output data to.
Comment 9 Răzvan Sandu 2008-11-02 06:02:42 EST
Created attachment 322212 [details]
pavucontrol - tab 1

Here are a few screenshots that shows how the various multimedia applications behave.
Comment 10 Răzvan Sandu 2008-11-02 06:03:22 EST
Created attachment 322213 [details]
pavucontrol - tab2
Comment 11 Răzvan Sandu 2008-11-02 06:04:13 EST
Created attachment 322214 [details]
pavucontrol - tab 3
Comment 12 Răzvan Sandu 2008-11-02 06:04:47 EST
Created attachment 322215 [details]
pavucontrol - tab 4
Comment 13 Răzvan Sandu 2008-11-02 06:05:46 EST
Created attachment 322216 [details]
An audio CD is just inserted...
Comment 14 Răzvan Sandu 2008-11-02 06:08:29 EST
Created attachment 322217 [details]
Rythmbox doesn't play

In rythmbox, selecting a CD track and pressing Play leads to no result (nothing happens).
Comment 15 Răzvan Sandu 2008-11-02 06:11:31 EST
Created attachment 322218 [details]
VLC plays at very low volume

VLC plays normally, but the sound volume is quite low (despite the fact that all other controls, both hardware and software, are set to maximum).
Comment 16 Răzvan Sandu 2008-11-02 06:13:52 EST
Created attachment 322219 [details]
Totem's option to play CDs is deactivated

Totem menu options for playing CDs is deactivated; it seems some plugin is needed, but none offered/found.
Comment 17 Răzvan Sandu 2008-11-02 06:19:55 EST
Created attachment 322220 [details]
Sound Juicer says invalid stream

Trying to play the CD with the Play option in Sound Juicer leads to the error in the image.

Please suggest other test to perform and I'll be pleased to experiment with them.

Thanks a lot,
Răzvan
Comment 18 Răzvan Sandu 2008-11-02 06:33:25 EST
Ripping a CD with SoundJuicer now produces .oga files instead of .ogg files.

Some players - for example XMMS - don't seem to know to open them. 

However, players that do know play .ogg files at normal volume level.


Răzvan
Comment 19 Lennart Poettering 2008-11-02 10:37:42 EST
You can change the volume of each playback stream (like the one from VLC) in pavucontrol. 

.oga is the standardized name for OGG audio files. Many older programs called that .ogg before.

Hmm, if you type "pacat /dev/urandom" in a terminal. Do you hear any noise?
Comment 20 Răzvan Sandu 2008-11-04 16:38:32 EST
Hello,

Even if sliders in pavucontrol are set to maximum (please see comment #11 above), volume is very low. Since this is a laptop, there are no cables to check...  ;-)

Of course, I know .ogg -> .ogg is just an extension change. But this simple change seems to confuse some players, according to my tests. Please try to open/play an .oga file by double-clicking it, when it is associated with various players installed on a Fedora system... The situation is similar on a Windows system.

Typing "pacat /dev/urandom" leads to:


[root@mazarin ~]# pacat /dev/urandom
Stream error: Invalid argument
[root@mazarin ~]# 


Regards,
Răzvan
Comment 21 Răzvan Sandu 2008-11-04 16:55:32 EST
For another example why renaming .ogg files to .oga still induces collateral problems (even if technically correct), please see bug #468464.

Răzvan
Comment 22 Răzvan Sandu 2008-11-19 03:32:07 EST
Hello,


Multimedia-related problems were present on my Dell Inspiron 1520 laptop since I've upgraded from Fedora 9 to rawhide (with daily updates) - as seen in comments above. IMHO, this is a regression.

For the moment, the most a annoying fact is that volume is very low, even if both hardware & software controls are set to maximum.

Could you please suggest a systematic way to double check all settings ?

This is the actual hardware profile of the laptop (smolt):

http://www.smolts.org/client/show/pub_9d69eb22-c7a0-44ea-9e54-a49aa186b94c


Thanks a lot,
Răzvan
Comment 23 Bug Zapper 2008-11-25 22:50:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 24 Lennart Poettering 2008-12-18 09:13:59 EST
Is this issue still current? Have you played around with "alsamixer -c0" to get the mixer initialized correctly?
Comment 25 Răzvan Sandu 2009-01-06 10:14:27 EST
Hello and thanks, 

Yes, this still happens. Sound is *very* low in *some* cases, especially on YouTube, despite the fact both software and hardware controls are set to maximum.

I didn't played with  "alsamixer -c0"; I'll do this today and let you know ASAP.

Regards,
Răzvan
Comment 26 Lennart Poettering 2009-02-24 20:44:35 EST
Hmm, I am pretty sure this is just another mixer initialization issue. Reassigning to alsa-libs, since it is now ALSA's job to come up with good default volumes.
Comment 27 Jaroslav Kysela 2009-03-17 07:23:21 EDT
Also, attach output from 'alsa-info.sh --no-upload'.
Comment 28 Bug Zapper 2009-11-18 02:56:36 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 29 Bug Zapper 2009-12-18 01:34:17 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.