Bug 466858 - Evolution requires now NetworkManager
Evolution requires now NetworkManager
Status: CLOSED DUPLICATE of bug 351101
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 03:09 EDT by Pawel Salek
Modified: 2008-10-17 11:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-17 11:29:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -q --requires NetworkManager-glib (970 bytes, text/plain)
2008-10-17 02:54 EDT, Pawel Salek
no flags Details

  None (edit)
Description Pawel Salek 2008-10-14 03:09:28 EDT
Description of problem:
Evolution requires NetworkManager since very recently, probably via NetworkManager-glib.

We have a number of thin clients with enough capacity to run evolution, firefox etc. All the networking, ip addresses, routes are static. However, since very recently, evolution demands that NetworkManager is installed. There is apparently something wrong with the dependency chain, I am not sure whether the fault is evolution's or NetworkManager-glib's.

I think it would be sensible to restore the list of dependencies to the previous one, that is, evolution should not (indirectly?) require NetworkManager.
Comment 1 Matthew Barnes 2008-10-14 07:00:03 EDT
Evolution has had a build requirement on NetworkManager since 2006, which is necessary for synchronizing its online/offline mode with network availability.
Comment 2 Pawel Salek 2008-10-14 07:09:04 EDT
Well, how do you explain then that I did not have NetworkManager installed so far and everything worked just fine? I think you confuse NetworkManager and NetworkManager-glib. If you want to close this bug, do it for the right reason. The one you specify does not explain the recent change in dependencies.
Comment 3 Matthew Barnes 2008-10-14 16:00:13 EDT
Nothing has changed on the Evolution side in this respect.
Comment 4 Pawel Salek 2008-10-14 16:09:07 EDT
Thank you. So it is apparently NetworkManager-glib which has started to require NetworkManager package, then. Reassigning.
Comment 5 Dan Williams 2008-10-15 10:49:30 EDT
No, NM-glib has always required NetworkManager indirectly because it requires libnm-util.so, which was provided by the NetworkManager package.  libnm-util has now moved into the NM-glib package, but because of multilib issues NM-glib must require NetworkManager as well.

So I'm pretty sure that nothing in the dependency chain has changed here either, since anything requiring libnm_glib.so has always required the NetworkManager package as well...

Can you get the following for us?

rpm -q --requires evolution
rpm -q --requires NetworkManager-glib
Comment 6 Pawel Salek 2008-10-17 02:54:36 EDT
Created attachment 320642 [details]
 rpm -q --requires NetworkManager-glib

I have checked the output and have come to following conclusions:
evolution requires libnm_glib - so far so good. I don't have a problem with evolution requiring NetworkManager-glib.

However, NetworkManager-glib requires explicitly NetworkManager! There is no library dependency here. This looks like a redundant requirement to me - what am I missing?
Comment 7 Dan Williams 2008-10-17 11:29:26 EDT
libnm_glib used to live in the main NetworkManager package.  To fix #351101 (which this bug is really a dupe of) the library was moved to NetworkManager-glib.  That, however, breaks multilib horribly, and thus for F9 and earlier there was an explicit dependency added between NetworkManager-glib and NetworkManager (#451519).

This is fixed in rawhide, but cannot be fixed in F9 and earlier due to the multilib issues.  You can turn NM off quite easily with 'chkconfig NetworkManager off' in your post-install scripts if you like and continue to use ifup/ifdown.

*** This bug has been marked as a duplicate of bug 351101 ***

Note You need to log in before you can comment on or make changes to this bug.