Bug 466870 - i945 will not display native resolution on external LCD
i945 will not display native resolution on external LCD
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 05:05 EDT by Alex Chiang
Modified: 2009-10-22 08:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-18 20:38:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (97.41 KB, text/plain)
2008-10-14 05:05 EDT, Alex Chiang
no flags Details
xorg.conf (1.85 KB, text/plain)
2008-10-14 05:07 EDT, Alex Chiang
no flags Details

  None (edit)
Description Alex Chiang 2008-10-14 05:05:27 EDT
Created attachment 320266 [details]
Xorg.0.log

Description of problem:
External LCD panel native resolution is 1440x900, built-in panel is 1400x1050.

I tried this incantation, but got fail:
$ xrandr --output VGA --auto

The external panel was refusing to do 1440x900; the panel's built-in electronics were saying that it was displaying 1280x960 (?? not totally sure on that second number since it doesn't seem to make sense to me, but that's what I vaguely remember).

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Connect external panel to laptop VGA port
2. Fail

  
Actual results:
External resolution of 1280x9xx.

Expected results:
External resolution of 1440x900

Additional info:
I cheated and got some help from keithp. I created an xorg.conf (since F10 doesn't ship with one by default) by issuing Xorg -configure.

Then, I added this magic:

        SubSection "Display"
                Viewport   0 0
                Depth     24
                Virtual 2048 2048
        EndSubSection

The Virtual 2048 2048 enabled this to work:

$ xrandr --output VGA --auto --output LVDS --off

And that enabled native resolution output on my panel.

So this bugzilla is more of an "fyi". I know next to nothing about X, but maybe there's something we can do to make F10 behave better for other users who don't know how to get in touch with keithp. i945 is a popular chipset...

I'm attaching my Xorg.log and xorg.conf.
Comment 1 Alex Chiang 2008-10-14 05:07:46 EDT
Created attachment 320267 [details]
xorg.conf

Created by running Xorg -configure as root.

I added the Virtual 2048 2048 line to the "Display" subsection and now xrandr does the right thing.

Note: I don't know what magic that actually enables, I just know that it fixed the problem for me. I'm hoping this bz will make sense to someone smarter than me.
Comment 2 Alex Chiang 2008-10-18 20:38:09 EDT
xrandr _does_ drive the external display at native resolution, even without an xorg.conf (implying also without that silly "Virtual 2048 2048" line).

[achiang@ethanol ~]$ yum info xorg-x11-drv-i810
Loaded plugins: refresh-packagekit
Installed Packages
Name       : xorg-x11-drv-i810
Arch       : i386
Version    : 2.4.2
Release    : 12.fc10

I don't know what happened or changed (maybe nothing), but this bug can be closed.

Unfortunately, X doesn't detect the panel's resolution correctly upon startup (bug 467357), so I still have to issue xrandr manually, but at least it now does the right thing.

Note You need to log in before you can comment on or make changes to this bug.