Bug 466871 - ibus engine setup should merge "started" and "preload" configuration
ibus engine setup should merge "started" and "preload" configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target 481098
  Show dependency treegraph
 
Reported: 2008-10-14 05:08 EDT by Jens Petersen
Modified: 2009-02-09 01:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-09 01:16:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2008-10-14 05:08:01 EDT
Description of problem:
ibus-setup has checkboxes for started and preload but I think this is too complicated for most used and they should just be merged into one option for simplicity since that is generally what one wants.  Maybe a start/stop toggle button could be added instead of started if it is useful - that would make the UI much clearer anyway: then selecting an engine should probably start it automatically and users could stop it temporarily if necessary by clicking on toggle state button.

Steps to Reproduce:
1. go to engines setup to choose engines
  
Actual results:
two sets of confusing checkboxes

Expected results:
single checkbox per engine

Additional info:
Being able to start/stop engines dynamically from the setup is a nice feature.
Comment 1 Bug Zapper 2008-11-25 22:51:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Jens Petersen 2009-02-09 01:16:55 EST
THanks, fixed in ibus-1.1.0

Note You need to log in before you can comment on or make changes to this bug.