Bug 466876 - An IOException occurred at scim_bridge_client_imcontext_set_cursor_location
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: scim-bridge (Show other bugs)
11
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 06:33 EDT by sangu
Modified: 2010-01-20 00:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 00:55:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2008-10-14 06:33:00 EDT
Description of problem:
]$ totem
** (totem:25091): DEBUG: Init of Python module
** (totem:25091): DEBUG: Registering Python plugin instance: YouTube+TotemPythonPlugin
** (totem:25091): DEBUG: Creating object of type YouTube+TotemPythonPlugin
** (totem:25091): DEBUG: Creating Python plugin instance

** (totem:25091): WARNING **: Unknown codec ID 86022, please add here
No accelerated IMDCT transform found
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
The messenger is now down
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
** (totem:25091): DEBUG: Finalizing Python plugin instance

$cat ~/.xsession-errors
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
An IOException occurred at handle_message ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()

$ dmesg | grep scim
scim-bridge[4318]: segfault at c ip 00190297 sp bfe6871c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[23142]: segfault at c ip 00190297 sp bff3c8fc error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[23211]: segfault at c ip 00190297 sp bf99a35c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[25007]: segfault at 433d454d ip 001982f7 sp bfaadf30 error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[25009]: segfault at c ip 00190297 sp bff28d6c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[25088]: segfault at c ip 00190297 sp bfe4247c error 4 in libscim-1.0.so.8.2.3[133000+cf000]


Version-Release number of selected component (if applicable):
0.4.15-7.fc10

How reproducible:
always

Steps to Reproduce:
1. Searching youtube on totem.
2. play youtube
3. Click Esc
  
Actual results:


Expected results:


Additional info:
totem-2.24.2-2.fc10.i386
Comment 1 Bug Zapper 2008-11-25 22:51:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 sangu 2008-12-24 22:50:43 EST
in Rawhide
Launch gnome-volume-control -> Select device in input or output tab -> Click ESC key -> scim-bridge Segfault
$gnome-volume-control
[...]
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()

$ dmesg | grep scim
scim-bridge[3353]: segfault at c ip 00190297 sp bfd49d5c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[3741]: segfault at c ip 00190297 sp bfe5493c error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[3916]: segfault at c ip 00190297 sp bf83a0ac error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[3979]: segfault at c ip 00190297 sp bfdff0dc error 4 in libscim-1.0.so.8.2.3[133000+cf000]
scim-bridge[4030]: segfault at c ip 00190297 sp bfa7c0ec error 4 in libscim-1.0.so.8.2.3[133000+cf000]

$ rpm -q scim-bridge gnome-media scim 
scim-bridge-0.4.15-8.fc11.i386
gnome-media-2.25.1-1.fc11.i386
scim-1.4.7-35.fc10.i386
Comment 4 Bug Zapper 2009-06-09 05:46:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Jan "Yenya" Kasprzak 2009-10-08 03:26:16 EDT
I have the similar (maybe the same) problem, but unrelated to totem: from time to time scim-bridge crashes, leaving all my gnome-terminals, galeon, and the mini_commander_applet without the keyboard input. I can switch to the text console, and in "ps ax|grep scim" I see the following processes:

 3514 ?        Ss     0:00 /usr/lib64/scim-1.0/scim-helper-manager
 3515 ?        Ssl    0:00 /usr/lib64/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
 3517 ?        Ss     0:00 /usr/lib64/scim-1.0/scim-launcher -d -c socket -e socket -f x11 --no-stay -d

When I kill the scim-launcher process, all the processes get restarted, leading to the following "ps ax|grep scim" output:

 7204 ?        Ss     0:00 /usr/lib64/scim-1.0/scim-helper-manager
 7205 ?        Ssl    0:00 /usr/lib64/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
 7207 ?        Ss     0:00 /usr/lib64/scim-1.0/scim-launcher -d -c socket -e socket -f x11 --no-stay -d
 7209 ?        Ss     0:00 /usr/lib64/scim-1.0/scim-launcher -d -c simple -e all -f socket --no-stay -d
 7210 ?        S      0:00 scim-bridge

and since then, the text input to gnome-terminal, galeon, and all the other GNOME apps works fine. The relevant part of .xsession-errors is probably the following one (altough I am not sure - I am writing this bug report some time after the last scim-bridge crash):

===============================
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException occurred at handle_message ()
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
The messenger is now down
** Message: Active session changed
** Message: Active session changed
An IOException at scim_bridge_messenger_receive_message (): Connection reset by peer
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_register_imcontext ()
Cannot register the IMContexts...
nt_register_imcontext ()
Cannot register the IMContexts...
The messenger is now down
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
GTK Panel of SCIM 1.4.8

Starting SCIM as daemon ...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
===============================

I think this started in F11 for me (I use scim-bridge for a longer time). Also, my system is x86_64, so the Platform: attribute of this bug can be changed to "All".
Comment 6 Jens Petersen 2009-10-08 23:51:38 EDT
(In reply to comment #5)
> I think this started in F11 for me

Could you try to reproduce with the scim-bridge from f10 then?
Comment 7 Jens Petersen 2009-10-08 23:53:49 EDT
(Additional comment: our general advice would be to switch to ibus
though - we are not really supporting scim as the primary input
method system in fedora.)
Comment 8 Jan "Yenya" Kasprzak 2009-10-09 04:27:36 EDT
I can reproduce the bug as described in comment #2 on a F11 system with F10 scim-bridge:

scim-bridge-0.4.15-8.fc10.x86_64
scim-bridge-gtk-0.4.15-8.fc10.x86_64
scim-bridge-gtk-0.4.15-8.fc10.i386

I will try ibus later.
Comment 9 Jan "Yenya" Kasprzak 2009-11-18 06:31:31 EST
Re: comment #7

I have switched to ibus and have not seen any IM-related crash since then.
It would be nice to have this bug fixed, but as for me, I don't care anymore :-)
Comment 10 Peng Huang 2010-01-20 00:55:30 EST
We have changed the default input framework to ibus. Please try it.

Note You need to log in before you can comment on or make changes to this bug.