Bug 466881 - impress crashes on startup with uninstalled, (but still registered) extension
impress crashes on startup with uninstalled, (but still registered) extension
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 06:41 EDT by Sarantis Paskalis
Modified: 2008-10-20 03:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-20 03:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash log (13.85 KB, text/plain)
2008-10-14 06:41 EDT, Sarantis Paskalis
no flags Details
profile.tar.gz (contains ~/.openoffice*) (1014.07 KB, application/x-gzip)
2008-10-14 08:00 EDT, Sarantis Paskalis
no flags Details
strace.log (6.88 MB, text/plain)
2008-10-14 08:38 EDT, Sarantis Paskalis
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 94938 None None None Never

  None (edit)
Description Sarantis Paskalis 2008-10-14 06:41:10 EDT
Created attachment 320276 [details]
crash log

Description of problem:
rawhide impress crashes on startup.  I upgraded to rawhide yesterday and impress could not open a (.odp) presentation created with openoffice 2.4 (it did not leave any traces).  I tried to create a new one with the same results (crash).


Version-Release number of selected component (if applicable):
openoffice.org-impress-3.0.0-9.3.fc10.i386


How reproducible:
Always

Steps to Reproduce:
1. run ooffice
2. create a new blank presentation
3. crash
  
Actual results:


Expected results:


Additional info:
crash log attached
Comment 1 Caolan McNamara 2008-10-14 06:51:55 EDT
It doesn't crash on startup for me.

Have you done anything like install the vanilla openoffice.org from www.openoffice.org previously ?

try this, 

cd
tar cjf /tmp/profile.tar.gz .openoffice*
rm -rf .openoffice*

and try to start OOo again.

If that works, please attach the /tmp/profile.tar.gz here so I can try and reproduce this here
Comment 2 Sarantis Paskalis 2008-10-14 08:00:53 EDT
Created attachment 320286 [details]
profile.tar.gz (contains ~/.openoffice*)
Comment 3 Sarantis Paskalis 2008-10-14 08:03:11 EDT
Oops, hit submit too soon.  This does not work, i.e. I see the same behavior (crash).  The profile is attached just in case.

Hardware profile at
http://www.smolts.org/client/show/pub_90609be1-1a82-4527-b731-5378ac85d1bd
(asus eeepc 900)
Comment 4 Caolan McNamara 2008-10-14 08:14:56 EDT
Very odd, especially to only get one report about it. Sort of looks like some starbasic package is causing the problem. How about a trusty strace to see what files were last to be opened before the crash, i.e.

yum -y install strace
strace -f ooimpress > /tmp/strace.log 2>&1

and attach the output of /tmp/strace.log
Comment 5 Sarantis Paskalis 2008-10-14 08:38:58 EDT
Created attachment 320290 [details]
strace.log

strace.log attached.  I should also note that this was a Fedora 9 install, some official Fedora updates, and yesterday a rawhide upgrade, i.e. nothing of non-Fedora repos.
Comment 6 Caolan McNamara 2008-10-14 09:12:05 EDT
Hmm, I think an extensions is screwed up.

"
[pid 11039] access("/usr/lib/openoffice.org3/program/../share/uno_packages/cache/uno_packages/p1zpgc_/writer2latex.uno.pkg", F_OK) = -1 ENOENT (No such file or directory)
"

What is the output of 

unopkg list --shared

ls -asl 
/usr/lib/openoffice.org3/program/../share/uno_packages/cache/uno_packages

ls -asl
/usr/lib/openoffice.org3/program/../share/uno_packages/cache/uno_packages/p1zpgc_/

ls -asl /usr/lib/openoffice.org3/program/../share/uno_packages/cache/uno_packages/p1zpgc_/writer2latex.uno.pkg

rpm -q openoffice.org-writer2latex

Looks like the openoffice.org-writer2latex extension may have gotten messed up during the upgrade somehow.
Comment 7 Sarantis Paskalis 2008-10-14 09:57:00 EDT
sarantis@localhost:~$ unopkg list --shared

ERROR: Error binding package: vnd.sun.star.expand:$UNO_SHARED_PACKAGES_CACHE/uno_packages/p1zpgc_/writer2latex.uno.pkg
       Cause: an error occured during file opening

unopkg failed.

sarantis@localhost:~$ ls  -asl /usr/lib/openoffice.org3/program/../share/uno_packages/cache/uno_packages
total 20
4 drwxr-xr-x 5 root root 4096 2008-10-13 14:54 .
4 drwxr-xr-x 4 root root 4096 2008-10-13 18:05 ..
0 -rw------- 1 root root    0 2008-10-13 14:54 dRpkJs
4 drwxr-xr-x 2 root root 4096 2008-10-13 14:54 dRpkJs_
0 -rw------- 1 root root    0 2008-09-02 12:30 p1zpgc
4 drwxr-xr-x 2 root root 4096 2008-09-02 12:30 p1zpgc_
0 -rw------- 1 root root    0 2008-10-13 12:26 svJd9a
4 drwxr-xr-x 2 root root 4096 2008-10-13 12:26 svJd9a_

sarantis@localhost:~$ ls -asl /usr/lib/openoffice.org3/program/../share/uno_packages/cache/uno_packages/p1zpgc_/writer2latex.uno.pkg 
0 lrwxrwxrwx 1 root root 32 2008-09-02 12:30 /usr/lib/openoffice.org3/program/../share/uno_packages/cache/uno_packages/p1zpgc_/writer2latex.uno.pkg -> /usr/share/writer2latex.uno.pkg/

sarantis@localhost:~$ rpm -q openoffice.org-writer2latex
openoffice.org-writer2latex-0.5.0.2-2.fc10.i386

I should mention that the link pointing to the writer2latex.uno.pkg is broken, i.e. there is no /usr/share/writer2latex.uno.pkg in the rawhide system, while there is such a directory in a Fedora 9 system.  writer2latex extension seems to have moved in rawhide in /usr/share/openoffice.org/extensions/writer2latex.oxt/ from  /usr/share/writer2latex.uno.pkg without updating the relevant openoffice registry.


- Removing the openoffice-writer2latex package did not solve the problem.
- Removing and reinstalling the openoffice-writer2latex package did not solve the problem.
- Removing all openoffice.org* rpms and reinstalling them solves the problem.

Thanks
Comment 8 Caolan McNamara 2008-10-14 11:25:19 EDT
The F-9 writer2latex must have failed somewhere during its de-install script, leaving droppings behind and not getting removed from the extensions list.

But if I revert to a F-9 openoffice.org-writer2latex and do a yum update, there isn't a problem. So I can't reproduce why it got broken.

Anyway. I can fake getting into the same situation with rpm --erase --noscripts openoffice.org-writer2latex. So I can reproduce being broken. Fix to keep-on-working if there is some problem with a particular extension has been checked in and will be in >= 3.0.0-9.4.

to-do: file upstream when post 3.0.0 download storm has passed and OOo bugzilla works again
Comment 9 Caolan McNamara 2008-10-20 03:55:50 EDT
Hopefully that'll avoid this happening again

Note You need to log in before you can comment on or make changes to this bug.